motor issue? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Builders Corner

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-30-2010, 11:28 AM   #1
Newb
 
Join Date: May 2010
Posts: 6
Question motor issue?

i dont have pics on comp yet but will soon. i have an issue with the 2.5 in my 89 wrangler, throttle body injection. when we drive it for a ways and shut it off it does not always start with key, runs really rich and if we push or pull start it, it will start right away?? i found on the throttle body a small hole which gas is dumping through and if i block it with my finger motor will run better, but how do i stop the gas from running through it? and do i have some sort of and ignition problem for the no start prob?? if anyone can help me i would much appreciate it, thanks from a new owner

newowner is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:06 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC