1992 YJ starting problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > Community Forums > WF New Member Check In

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-19-2012, 12:54 PM   #1
Newb
 
DaggersEdge's Avatar
 
Join Date: Oct 2012
Posts: 5
1992 YJ starting problems

I’m trying to get my 1992 YJ road ready for my daughter. It has been a couple of years since it was on the road. I have gotten her running after changing the fuel injectors, the fuel pump, this kept her running for about a week then I lost fuel pressure in the fuel rail and had no spark. I then replaced the crank position sensor, the throttle position sensor, the coil, the distributor cap, the spark plugs and wires. Still no luck, until I left the key in the on position for about twenty minutes when I hear the shut down and the fuel relay start clicking. I turned off the key and then tried to start it and she did finally fire but would not stay running.

The boss on the distributor was cut off about 10 years ago by a former friend I had work on it the last time I had an issue with her running (big mistake ever letting him touch my ride). I adjusted the distributor a few times and finally got her to run. After she warmed up she started to spit and sputter, so I repositioned the distributor again until she smoothed out. I was then able to drive her for hours with not issue. I could shut her off and she’d start right back up.

However the next day again I had nothing, I also noticed that neither my “Check Engine” nor my “Maintenance Required” light come on when I turn the key or try to start her. I replaced the relays and still noting. I added two more grounding cables on to the motor and one to the body. Still have to leave the key in the on position until the relays start to tick at which time the “Maintenance Required” lights will flicker in sync with the relays ticking. Again I had to reposition the distributor to get her to stay running and reposition after she warms up.

I thought maybe I have a bad contact at the ECM so I removed the unit cleaned the contacts and greased them again, I also did the same thing to the fuse block connections at the firewall since I was already there. Issue still remains.

I am thinking about replacing the distributer in hopes of curing the repositioning issue, but I am at a loss as to what to do to about the 20 minute wait until the relays tick. Any help would be appreciated, thanks.

DaggersEdge is offline   Quote
Old 10-19-2012, 05:39 PM   #2
K O R

WF Supporting Member
 
dabolt55's Avatar
 
Join Date: Jul 2011
Location: Clinton, Tn.
Posts: 13,287
Images: 52
Since this is where we welcome new people here, post in this section>>YJ Jeep Wrangler Forum
Welcome..

__________________
Nothing to it but to do it.
SIMPLE AS THAT.

'04 TJ RUBICON, 4.0l auto
2"BDS coils, Rubicon express shocks, 33/12.50/15 Dick Cepek Mud Country tires yellowed out, on Black steel D's.
http://www.wranglerforum.com/f115/ne...s-1133034.html
dabolt55 is offline   Quote
Old 10-19-2012, 06:54 PM   #3
Thank You Veterans!

5-Year WF Supporting Member
::WF Moderator::
 
Beastmaster's Avatar
 
Join Date: Aug 2011
Location: The Old Pubelo
Posts: 26,174
Quote:
Originally Posted by dabolt55 View Post
Since this is where we welcome new people here, post in this section>>YJ Jeep Wrangler Forum
Welcome..
^^^^^^

Welcome to the forum!

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)
Beastmaster is online now   Quote
Old 10-19-2012, 07:59 PM   #4
Jeeper
 
SilverSport's Avatar
 
Join Date: May 2011
Posts: 22,969
Send a message via Yahoo to SilverSport
Welcome Aboard!
__________________
"Own a Jeep and own a piece of history."

"The Hunter is not concerned with the opinion of the Wolf."
SilverSport is offline   Quote
Old 10-20-2012, 05:37 AM   #5
Jeeper
 
MrSig's Avatar
 
Join Date: Aug 2011
Location: Davie, Fl
Posts: 20,495
and enjoy the forum!
__________________
07 JKU to see my mods or Jeep in action go to http://www.aaof.us/jeep.htm
CEO of Black Sheep 4x4s org,
Member of CCJ, White Jeep Club Member #137.
MrSig is offline   Quote
Old 10-20-2012, 02:11 PM   #6
jokerchief462

WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 9,763
Welcome to the forum. Looking forward to your posts in the YJ pages.

jokerchief462 is offline   Quote
Reply

Tags
cps , distributor , ecu , relay , tps

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:26 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC