New to Forum with a question about my 93 Wrangler - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > Community Forums > WF New Member Check In

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-30-2010, 12:29 PM   #1
Newb
 
Join Date: Sep 2010
Posts: 2
New to Forum with a question about my 93 Wrangler

Hello out there fellow Jeepsters. I'm from Northern California and I have a 1993 jeep Wrangler 4 cyl 5 Spd 2.5 ltr.
Lately I've noticed that my check engine light comes on and that I'm going through a lot of oil with no apparent leakage places. However I did notice that there is a lot of oil building up in the breather. I took it out and cleaned it with hot soapy water and then let it dry before replacing it. The check engine light went off. Then after no more than a couple of hundred miles the light came back on and the breather was full of engine oil again. Any ideas how to solve this without payinga mechanic? Thanks all.

tlynn77 is offline   Quote Quick Reply
Old 09-30-2010, 12:43 PM   #2
Jeeper
 
blkrubi88's Avatar
 
Join Date: Nov 2009
Location: Clayton NC
Posts: 23,678
Welcome to the forum! You might want to post your question in the YJ section for better response if you don't get an answer here!

blkrubi88 is online now   Quote Quick Reply
Old 10-01-2010, 01:05 AM   #3
Jeeper
 
Ageless Stranger's Avatar
 
Join Date: Apr 2010
Posts: 26,792
Welcome to WF.
Ageless Stranger is offline   Quote Quick Reply
Old 10-01-2010, 03:20 AM   #4
Jeeper
 
Yjwolf's Avatar
 
Join Date: Oct 2010
Posts: 466
Common problem with both 4 bangers and 6 cy. There's a build up of gunk in your valve cover preventing ventilation. It's like haveing a bad PVC valve. Pull the cover clean it up real good and it should fix it. Had this prob with my 4.0 and my dads 4cy
Yjwolf is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turning Wrangler Forum Facebook Fans & Recent Threads off? Jerry Bransford WF Site Help & Support 3 02-21-2010 10:01 AM
Wrangler Forum Jeep Club jgano23 Off-Topic 73 04-10-2009 08:46 PM
2008 Wrangler X 4 X 4 question Kroe JK Tech Forum 1 07-20-2008 11:33 PM
Wrangler Forum late summer trail ride???? 4Jeepn On The Trail 17 09-22-2007 09:48 AM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:43 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC