New to this Forum, looking for some help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > Community Forums > WF New Member Check In

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-27-2010, 05:41 PM   #1
Newb
 
Join Date: Sep 2010
Posts: 5
New to this Forum, looking for some help

Hello fellow Jeep owners (well, most of you).

I'm looking for some advice from someone who knows something about fuel injector problems.

But first, I'll introduce myself. I'm a 63 year old mother of 9 children, 4 step children, and 19 grandchildren. I've owned my 1995 Jeep Grand Cherokee Laredo since November 2002, and I love it. Has got me through many snowy and icy situations.

I used a similar forum about 6 years ago when my Jeep was having some problems, and the most likely answer was a crank position sensor problem. I mentioned that to my mechanic (we lived in a rural area in Nevada at the time), and he had never heard of that!! Unbelievable! Anyway, I finally got it to a Jeep dealership in Salt Lake City and got it fixed. Nice to meet someone who believed me, and knew what I was talking about.

In May I had a tuneup done, and they also serviced the fuel injector. My Jeep has always started with the first crank, even at 40 below. Now it just cranks and cranks if it has been sitting for more than 5 or 10 minutes. Some kind of check valve problem, I believe, but for some reason they can't find it. I took it back and they told me (after having the car for 2 days) that it was NOT the fuel pump. I already knew that as I had that replaced at the time I got the crank position sensor replaced.

Sure hope someone has some ideas for me to pass along to the mechanic since this is getting very frustrating.

Thanks!

SusanH is offline   Quote Quick Reply
Old 09-27-2010, 09:44 PM   #2
Jeeper
 
jeepgurl6969's Avatar
 
Join Date: Aug 2010
Location: Tennessee
Posts: 49
Send a message via Yahoo to jeepgurl6969
Quote:
Originally Posted by SusanH View Post
Hello fellow Jeep owners (well, most of you).

I'm looking for some advice from someone who knows something about fuel injector problems.

But first, I'll introduce myself. I'm a 63 year old mother of 9 children, 4 step children, and 19 grandchildren. I've owned my 1995 Jeep Grand Cherokee Laredo since November 2002, and I love it. Has got me through many snowy and icy situations.

I used a similar forum about 6 years ago when my Jeep was having some problems, and the most likely answer was a crank position sensor problem. I mentioned that to my mechanic (we lived in a rural area in Nevada at the time), and he had never heard of that!! Unbelievable! Anyway, I finally got it to a Jeep dealership in Salt Lake City and got it fixed. Nice to meet someone who believed me, and knew what I was talking about.

In May I had a tuneup done, and they also serviced the fuel injector. My Jeep has always started with the first crank, even at 40 below. Now it just cranks and cranks if it has been sitting for more than 5 or 10 minutes. Some kind of check valve problem, I believe, but for some reason they can't find it. I took it back and they told me (after having the car for 2 days) that it was NOT the fuel pump. I already knew that as I had that replaced at the time I got the crank position sensor replaced.

Sure hope someone has some ideas for me to pass along to the mechanic since this is getting very frustrating.

Thanks!
I found this comment posted on another site maybe this will hep you out:

I've had 3 Jeeps all with the same faulty CKP or crank shaft position sensor(yes, this is the right abbreviation). My 1998 Jeep GCL just stopped working 2 days ago. It stalled, the gas guage went to 'E', but the rest of the guages worked fine. It would crank, but not start...like it wasn't getting any fuel. I checked the fuel rail for fuel pressure to the Fuel Injectors (checked OK). Then I checked for Ignition Spark(Checked Bad), I replaced the Ignition Coil, still NO SPARK. Next was the Distributor Cap and Rotor. The rotor and cap showed signs of excessive wear, so I replaced them, too. Still, the Jeep won't start. The Fuel Pump was checking OK, too.

My initial thought was that the CKP was bad, but I did R/R the ignition coil, rotor and distributor cap as preventative maintenance, just in case I was wrong(they needed to be replaced, anyway due to normal wear). Then, I gave in and Removed and Replaced the CKP. The Jeep started and runs great.

Its on the driver side, top rear of the Bell Housing. You must jack up the vehicle to get to it. Follow the wire harness, remove the attaching bolt, slide it out the CKP, insert the new one, reattach the bolt, re-connect the wire harness. The Jeep should start within 1-3 cranks of the ignition. Good Luck!

jeepgurl6969 is offline   Quote Quick Reply
Old 09-27-2010, 10:51 PM   #3
Newb
 
Join Date: Sep 2010
Posts: 5
Thanks. I am inclined to think this is some kind of fuel injector check valve problem. My car started just fine, at any temperature, until the injector was serviced. Took it in for a tuneup initially. It acts like all the fuel has drained away to the tank. Just had the crank position sensor replaced 5 years ago. and the vehicle has not had any of the symptoms it had at that time. Just frustrating because I took the car back in to the repair shop and told them about the starting problem, that it was not that way before they worked on it, and they had it for 2 days and all they told me was that the fuel pump was working. It's my only transportation, and they don't have a loaner car, so I can't just leave it while they play with it. I have to get to work.

Thanks for your response, though. I appreciate it when someone takes time to answer me.

Susan
SusanH is offline   Quote Quick Reply
Reply

Tags
fuel injector , starting problems

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New To Wrangler Forum n116ebo WF New Member Check In 11 09-23-2010 10:59 PM
forum turds brokenarrow33 TJ General Discussion Forum 36 07-27-2010 04:08 PM
Forum policy - check in here before listing something! JeepCrawler98 Classifieds Archive 0 04-05-2005 09:34 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:28 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC