not firing - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > Community Forums > WF New Member Check In

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 11-28-2012, 02:54 PM   #1
Join Date: Nov 2012
Location: houston
Posts: 1
Exclamation not firing

well, first off, im a newbie. howdy yall! anyways, about 2 months ago, while going about 55-65 mph, the jeep would stutter, as if it was dying, for a couple of seconds, then it would go back to normal, and a burnt type smell would come immediately after. at first, every once in a while it would stutter. fast forward to last month. it got to where i couldnt get out of first gear before it would start to choke out. i took it to midas and paid 720 for a new fuel pump. runs fine for a day, then boom, same prob. so, i decided to change out the injectors, plugs and wires. did plugs and wires first, drove it around the block. same problem. so i did the injectors. did everything by the book, manual and all. got everything put back on, turned the key 10 times to prime pump like i read, and that leads me to my problem. its cranking, but wont fire. started to sputter(barely) but now, just cranks. what do i do? ANY response will be more than welcome as im at a complete standstill. thank you

dont_tread_on_me is offline   Quote
Old 11-28-2012, 04:31 PM   #2
SilverSport's Avatar
Join Date: May 2011
Posts: 25,866
Send a message via Yahoo to SilverSport
Welcome Aboard! Post your question in the YJ forum here for help: YJ Jeep Wrangler Forum - Jeep Wrangler Forum

"Own a Jeep and own a piece of history."

"The Hunter is not concerned with the opinion of the Wolf."
SilverSport is offline   Quote
Old 11-28-2012, 05:02 PM   #3

5-Year WF Supporting Member
dabolt55's Avatar
Join Date: Jul 2011
Location: Clinton, Tn.
Posts: 16,187
Welcome and good luck...
Nothing to it but to do it.

'04 TJ RUBICON, 4.0l auto
2"BDS coils, Rubicon express shocks, 33/12.50/15 Dick Cepek Mud Country tires yellowed out, on Black steel D's.
dabolt55 is offline   Quote
Old 11-28-2012, 06:30 PM   #4
Thank You Veterans!

5-Year WF Supporting Member
::WF Moderator::
Beastmaster's Avatar
Join Date: Aug 2011
Location: The Old Pubelo
Posts: 30,384
Welcome to the forum!

/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)
Beastmaster is online now   Quote
Old 11-28-2012, 10:15 PM   #5
Supporting Member

5-Year WF Supporting Member
jokerchief462's Avatar
Join Date: Apr 2012
Location: North Las Vegas
Posts: 10,046
Welcome to the forum and congrats on the YJ!!! Tough to keep running check out the YJ page and get all the help you need. See you there!!!
jokerchief462 is offline   Quote
Old 11-29-2012, 04:08 AM   #6
MrSig's Avatar
Join Date: Aug 2011
Location: Davie, Fl
Posts: 23,626
and enjoy the forum!

07 JKU to see my mods or Jeep in action go to
CEO of Black Sheep 4x4s org,
Member of CCJ, White Jeep Club Member #137.
MrSig is offline   Quote

just did injectors , not firing

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:31 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC