o2 sensor prob - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > Community Forums > WF New Member Check In

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-12-2012, 08:29 AM   #1
Newb
 
Join Date: Jan 2012
Location: Hudson valley up state NY
Posts: 4
o2 sensor prob

My 07 jeep wrangler has been showing a problem with the o2sensor #2 bank two for a year last year I had the dealership replace it for over a$100 bucks and it dident stay fixed is there any permanent fix or way to eliminate it altogether so it can pass NY state inspection.

I.B.Deadly is offline   Quote
Old 01-12-2012, 08:44 AM   #2
Jeeper

WF Supporting Member
 
kbwwolf's Avatar
 
Join Date: Sep 2011
Location: Wisconsin
Posts: 12,286
Post this in the JK Jeep Wrangler section...somebody will know something. Obviously I do not, or I'd save you the trouble.

Welcome to WF.

__________________


"What we see depends mainly on what we look for."
—John Lubbock
kbwwolf is offline   Quote
Old 01-12-2012, 09:01 AM   #3
jcf
Bludger

WF Supporting Member
 
jcf's Avatar
 
Join Date: Dec 2008
Location: Moab UT
Posts: 12,824
Send a message via Yahoo to jcf
Welcome to WF
jcf is offline   Quote
Old 01-12-2012, 11:01 AM   #4
Jeeper
 
Templar's Avatar
 
Join Date: Dec 2011
Location: Maryland
Posts: 1,616
Welcome to WF
__________________
2012 Wrangler Sport 4x4
Auto / 3.73 / Hard Top / Tint / Infinity Speakers
Power Convenience / Connectivity

U.S. Army 88 - 93
Templar is offline   Quote
Old 01-12-2012, 02:37 PM   #5
Thank You Veterans!

5-Year WF Supporting Member
::WF Moderator::
 
Beastmaster's Avatar
 
Join Date: Aug 2011
Location: The Old Pubelo
Posts: 28,079
Welcome to the forum!

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)
Beastmaster is online now   Quote
Old 01-12-2012, 04:14 PM   #6
Sponsoring Vendor
 
1ATony's Avatar
 
Join Date: May 2010
Posts: 2,049
Welcome to the site.
__________________

CLICK HERE^^^ TO SEARCH FOR JEEP PARTS

Facebook|YouTube|Instagram
1ATony is offline   Quote
Old 01-12-2012, 09:29 PM   #7
I am JD and it's My Dream

WF Supporting Member
::WF Administrator::
 
JDsDream's Avatar
 
Join Date: Jan 2009
Location: The Peach State
Posts: 27,837
Welcome to the Forum

Although I drive a TJ, I was having the same problem. CEL would come on and go off randomly always showing one or another of the O2 sensors being the culprit. It could be that they replaced the wrong sensor or as in my case it was a leak in the manifold that was causing the bad O2 sensor codes.
__________________
The kind of woman that when my feet hit the floor each morning the devil says "Oh Crap, She's up!"

To All Of Our Forum Veterans and Active Service Members.
Our Debt To You Is Greater Than We Could Ever Repay.
Thank You

Become a Supporting Member!
JDsDream is offline   Quote
Old 01-13-2012, 05:12 AM   #8
Jeeper
 
blkrubi88's Avatar
 
Join Date: Nov 2009
Location: Clayton NC
Posts: 25,622
Welcome!
__________________
I can only please one person a day and today is not your day and tomorrow is not looking good either!



CHRIS
blkrubi88 is online now   Quote
Old 01-13-2012, 09:29 PM   #9
Newb
 
Join Date: Jan 2012
Location: Hudson valley up state NY
Posts: 4
Thanks for the Advice I'll check the manifold and try the jk page

I.B.Deadly is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 12:31 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC