89 Jeep wrangler runs rough and then stalls - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-19-2010, 06:28 PM   #1
Newb
 
Join Date: Jul 2010
Location: michigan
Posts: 4
Angry 89 Jeep wrangler runs rough and then stalls

so.....! i'm working on this 89 jeep wrangler 2.5L engine 5 speed , and instead of just doing the whole parts replacing like some people i'm trying to find the actual problem on hand! first the jeep would not start and it wasn't getting any spark so i started immediatly at the crank sensor! got the jeep running! now its running rough as hell! I replaced every vacuum hose! i don't think the tps is reading anything, haven't tested it yet!, but i know that the egr valve is completely stuck closed! i already have done a tune up on it , and the previous owner replaced the coil and ignition module behind the coil! so i guess what i'm asking is, would the tps make this thing run like crap like that? or the combo of both the egr and the tps. also the exhaust is broken right at the manifold! so the O2 sensor isn't getting the correct reading either but i don't think that would make this run the way it does!

bigguns027 is offline   Quote Quick Reply
Old 07-19-2010, 06:53 PM   #2
The Bad Guy

WF Supporting Member
 
daggo66's Avatar
 
Join Date: May 2009
Location: NJ exile living in Baltimore
Posts: 22,199
Does it have fuel injection or a carb?

__________________
Tom

"I've got two things in this world, my balls and my word and I don't break them for no one."
daggo66 is offline   Quote Quick Reply
Old 07-20-2010, 12:45 AM   #3
Newb
 
Join Date: Jul 2010
Location: michigan
Posts: 4
its fuel injected, two fuel injectors are mounted inside on the top of the throttle body! i already checked the fuel pressure, 46 lbs! its good !
bigguns027 is offline   Quote Quick Reply
Old 06-17-2011, 09:23 AM   #4
Newb
 
Join Date: Jun 2011
Location: stockbridge, MI
Posts: 2
2 injectors?

my 88 only has 1. you sure thats a stock throttle body?
liberator365 is offline   Quote Quick Reply
Old 06-17-2011, 09:45 AM   #5
Jeeper
 
Shelby427's Avatar
 
Join Date: May 2011
Location: Lakeland FL and Hooversville PA
Posts: 2,130
Yep faulty TPS, and an EGR will make it run terrible, also no signal from the O2 sensor, and it's probably running full rich.
__________________
97 Sahara, 74 Renegade, 72 CJ5, 55 Willy's (the Beast) Boss 302, 6:34 gearing, Bose 901 speakers.
God I miss that Jeep. Forgot the kinda Jeep, 80 SX4.
Shelby427 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 11:30 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC