97 Wrangler getting real hot after running while not showin on gauges! Help please!!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-27-2013, 09:07 PM   #1
Newb
 
Jdownhour17's Avatar
 
Join Date: Aug 2013
Posts: 4
I just recently purchased a 97 Wrangler and I've noticed that after I drive for about 15-20 minutes or so the engine and flooring is really unusually hot. The gauge is reading at 210 and has never went above. I've checked the fluid and everything is good and it doesn't look gunky or real dirty. Everything that you usually check when you think your vehicle is overheating is adding up here and I can't seem to figure it out. I'm not very mechanically inclined so any help would be appreciated much! Thanks!!

Attached Thumbnails
Click image for larger version

Name:	image-1685308693.jpg
Views:	19
Size:	127.5 KB
ID:	291486  

Jdownhour17 is offline   Quote Quick Reply
Old 08-28-2013, 07:55 AM   #2
jokerchief462

WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 9,374
No cel or codes??? Running rich maybe it is the catalytic converter???

__________________
89 2.5 TBI, 4" RC lift, 1" Booms, SYE, Adams Driveshafts front and rear, Ford 8.8 with 4:88s, BFG 33X12.50X15, and a ton of other stuff.

AF Jeep Club Tail Number 184
jokerchief462 is offline   Quote Quick Reply
Old 08-28-2013, 08:42 AM   #3
Newb
 
Jdownhour17's Avatar
 
Join Date: Aug 2013
Posts: 4
Check engine light is on but thermostat reads 210 constantly unless it hasn't been running for a while. I haven't checked for codes yet. Around the shifter it gets real hot and you can feel the hood after about a 20 minute drive and its hot. I'm trying to simplify things down so that I don't spend an arm and a leg experimenting with parts.
Jdownhour17 is offline   Quote Quick Reply
Old 08-28-2013, 08:51 AM   #4
jokerchief462

WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 9,374
She is probably running rich which builds a lot if extra heat in the cat.
__________________
89 2.5 TBI, 4" RC lift, 1" Booms, SYE, Adams Driveshafts front and rear, Ford 8.8 with 4:88s, BFG 33X12.50X15, and a ton of other stuff.

AF Jeep Club Tail Number 184
jokerchief462 is offline   Quote Quick Reply
Old 08-28-2013, 11:55 AM   #5
Newb
 
Jdownhour17's Avatar
 
Join Date: Aug 2013
Posts: 4
Got the light checked. O2 sensor is out and catalytic converter is bad. Thanks for the advice
Jdownhour17 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 07:38 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC