Accelerator Loses Function - Help please - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-03-2012, 11:31 AM   #1
Newb
 
Join Date: Dec 2010
Posts: 9
Exclamation Accelerator Loses Function - Help please

As I'm driving down the road, suddenly my accelerator becomes useless, the Jeep jerks as it drastically slows down and I begin to coast. Pushing on the gas pedal does nothing. The engine continues to run as if in neutral, I still have my power steering and radio. The check engine light goes on only during the incident, then goes off again as soon as the engine "engages" again. There is no other unusual mechanical noise. Actually, I just said it seems in neutral, but upon further thought, it seems to decelerate even quicker than it would, if I had just put it in neutral. It feels more like a downshift from 4th to 3rd gear... but the RPMs don't increase. They decrease.

For the past six weeks or so, it would occasionally happen for about half a second, and the vehicle would jerk (my body would jerk forward). It happened maybe one or two times a week, sometimes less. Normally I'm traveling about 45 mph. One time it happened while I was idling at a red light, but only for that half second; so I couldn't really tell if the engine was going to die.

But last night it got worse, and twice, within three minutes, it happened again... but it lasted a good 4 or 5 seconds. It seems like its instantly shutting down, but didn't completely shut down within those 5 seconds. Slowed down very quickly, and my gas pedal had no effect. Frankly, I was more focused on not getting rear-ended, than I was about observing what was going on. It was quite alarming, as it was on a single lane road with no shoulder, during evening rush hour. Luckily they guy behind me wasn't quite close enough to rear end me during my quick deceleration. I can't count on that luck again.

Had it checked right away with a meter at the auto parts store. They found no bad codes.

I put in some fuel injector cleaner, as it was the only thing I could try quickly and crossed my fingers for the last 6 miles home. Nothing happened during that time. Nor during 15 miles this morning.

The vehicle is a '99 Wrangler 4x4, 6 cyl., 4.0

The guy at the auto parts had some suggestions, but anything he could think of, he says would have showed up as an error code on the meter. (ie fuel pump) I've considered the fuel filter (internal gas tank, sock type). Is there anything I've described that might eliminate the fuel filter as the culprit? Perhaps it's an engine speed sensor? I can check some mechanical issues, but am useless if it's an electrical problem. I have heard that there is a sensor I can plug into computer and drive around with it several days, that will record any intermittant code errors that clear themselves. As I said, the auto parts guy found nothing when he used his sensor. Anyone know what type of shop has the sensor I can leave in for a few days? Would that be a good idea?

Would loose or shorting coil wires?

Does anyone have an opinion if these symptoms point more to fuel issue, or electric issue?

The situation is somewhat alarming, as there is nowhere to pull over during most of my daily ride. If the fuel injector cleaner didn't fix it, it could eventually end badly.
Suggestions?

WunGoodGuy is offline   Quote Quick Reply
Reply

Tags
accelerator

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 07:04 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC