Alarm from dashboard - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-27-2014, 07:58 AM   #1
Newb
 
Join Date: Jan 2014
Posts: 4
Alarm from dashboard

I've tried searching multiple ways and couldn't find an answer.

My right front turn signal went out so I replaced the bulb and everything seemed fine until this morning - it sat over the weekend. I started it up and noticed the right turn signal light on the dashboard was steady on. When I moved the turn signal lever to on it did that fast blinking so I figured something was up but it was 5:30am and I had to get to the van pool to get to work. On the way there, about 3 miles into the drive, at about 50mpg, I started hearing this alarm coming out of the dashboard. As I slowed down for a traffic light, the alarm stopped. It stayed off for about 2 miles at which point I was going about 55 mph. I pulled into the parking lot and as I slowed down, it stopped again. This whole time the turn signal was steady on.

Any ideas?

Lemarchand is offline   Quote Quick Reply
Old 01-27-2014, 11:45 AM   #2
Newb
 
Join Date: Jan 2014
Posts: 4
Just a follow up - This is a 2002 Wrangler Sahara with no alarm system. Just LoJack.

Lemarchand is offline   Quote Quick Reply
Old 01-27-2014, 12:46 PM   #3
Jeeper
 
2five22's Avatar
 
Join Date: Jul 2012
Posts: 1,387
Been in water lately? Fording streams, rain? Is your flasher mechanical or electronic?
2five22 is offline   Quote Quick Reply
Old 01-28-2014, 08:51 PM   #4
Jeeper
 
Riptide63's Avatar
 
Join Date: Apr 2007
Location: Pensacola, Florida
Posts: 281
Mine did that when it had moisture in the front turn signal.
__________________
Doug Coleman

2000 Wrangler Sport - "Red" - Stock
1999 Z-28 - "The GLUMAKR" - Not Stock

"Mid-life crisis? Pfffffttt... more like a whole-life crisis."
Riptide63 is offline   Quote Quick Reply
Old 01-28-2014, 11:43 PM   #5
Jeeper
 
Lando25's Avatar
 
Join Date: Feb 2011
Location: Southern Minnesota
Posts: 1,047
I had something similar happen last summer, started by replacing the flasher but after chasing down the problem with an ohm meter I ended up replacing the bulb socket which did the trick.
__________________
sic vis pacem para bellum
OlllllllO
Lando25 is offline   Quote Quick Reply
Old 01-30-2014, 08:26 PM   #6
Newb
 
Join Date: Jan 2014
Posts: 4
Thanks everyone. Yes - lots of rain and cold in SE Texas lately. I had some water in the housing for the front right turn signal a couple of weeks ago and the bulb went bad so I relaxed it after drying everything out. For some reason it was fast blinking when I went into a restaurant but when I came out 90 minutes later it was working fine. Then I left it parked in the driveway for three days because of the weather and now it fast blinks again. Go figure.
Lemarchand is offline   Quote Quick Reply
Old 01-30-2014, 08:27 PM   #7
Newb
 
Join Date: Jan 2014
Posts: 4
Replaced not relaxed
Lemarchand is offline   Quote Quick Reply
Old 01-30-2014, 11:58 PM   #8
Jeeper
 
Lando25's Avatar
 
Join Date: Feb 2011
Location: Southern Minnesota
Posts: 1,047
Like I said above this sounds exactly what happened to me. Mine would blink fast for a trip to work then on the way back be fine. One day it decided to just not light up. The bulb socket got too much moisture inside it and shorted out.
__________________
sic vis pacem para bellum
OlllllllO
Lando25 is offline   Quote Quick Reply
Old 03-12-2014, 12:53 PM   #9
Jeeper
 
donbadabon's Avatar
 
Join Date: Dec 2011
Location: Northeast Arkansas
Posts: 225
The alarm you hear is the alarm that comes on when you normally forget to turn off your turn signal and keep driving with it on.

That is why it turns off when you slow down, it thinks you are getting ready to turn. When you speed back up it will come on again.

Temporarily you can try flicking your turn signal to the right or left and see if that resets the trigger. If it does, it is just a temporary solution. You'll eventually have to track down the issue if you want it to permanently stop.

donbadabon is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:03 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC