Check Engine Light(Vacuum leak) - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-10-2012, 01:19 PM   #1
Newb
 
Join Date: Dec 2012
Posts: 2
Exclamation Check Engine Light(Vacuum leak)

My jeep has been acting funny for the past week. It dies when Im going slow (under 40mph) and the oil pressure gauge has shown it all the way up (80.) However, my check engine light is on and I suspect it has something to do with a vacuum leak. But Im not sure what to do to fix a vacuum leak (besides getting a new tube.) Also, I have no idea how to find the leak in the first place.

When I drive at higher speeds (70-90mph) the oil pressure gauges reads at 40-50.

Any ideas on what is wrong or how to fix it?

Guilty Spark is offline   Quote
Old 12-10-2012, 02:03 PM   #2
Jeeper
 
Baby Huey's Avatar
 
Join Date: Feb 2012
Location: Western Washington County Oregon
Posts: 1,185
A Vacuum leak is usually a loose or disconnected vacuum hose....Most of the time with engine running you will hear a noise from the leak. If not check all your hoses under the hood and both ends !! Sometimes hoses get hard and crack, you won't see the bad part unless you bend the hose ...Hose is available at any Auto parts store or hardware store.
If you have a Check Engine light on, I'd take it to a Auto Zone or O'Riley's and have em check the codes and see just what the problem is......
"BH"

__________________
07-JKU-X /Poison spider Evap.Skid/Master craft grab handles/Or-Fab spare tire-can carrier/ Gibson SS Duals/ Q-tec Floor Liners/Hidden Hitch Receiver/ AntennaX 7inch/ 48" Hi-Lift./ 8"X16"X4"bs Steel smoothie wheels/ 265X75R-16 Kelly Safari TSR tarz.

Viet Nam Veteran 69-70, Troop "D" (AIR) 3/4 Cav. ,25th Inf. Div. CUCHI RVN. UH-1H Crew Chief of the "Pinball Wizard" 68-16224. Call Sign "CENTAUR".
Baby Huey is offline   Quote
Old 12-10-2012, 02:17 PM   #3
Newb
 
Join Date: Dec 2012
Posts: 2
I have taken it to AutoZone and all they could tell me was there was a vacuum leak. They weren't able to track it down. I checked all my hoses and found a few that had cracks in them and fixed them. But after a couple weeks the light came back on and now I am back at square one.

The biggest issue I am worried about is the oil pressure. I can't seem to figure the issue there. I changed the oil not even 3,000 miles ago.
Guilty Spark is offline   Quote
Old 12-10-2012, 03:32 PM   #4
Jeeper
 
Baby Huey's Avatar
 
Join Date: Feb 2012
Location: Western Washington County Oregon
Posts: 1,185
Try a new Sending unit......you can get em at any Autoparts store , not too expensive...

40-50 psi at high speeds is pretty "normal"...for oil pressure.
No less than 25-30psi at idle.

Vacuum leak could also be a bad intake manifold gasket, bad PCV valve, if it hangs open it will cause a vacuum leak... cause your engine to stall and die...
Just some ideas...."BH"
__________________
07-JKU-X /Poison spider Evap.Skid/Master craft grab handles/Or-Fab spare tire-can carrier/ Gibson SS Duals/ Q-tec Floor Liners/Hidden Hitch Receiver/ AntennaX 7inch/ 48" Hi-Lift./ 8"X16"X4"bs Steel smoothie wheels/ 265X75R-16 Kelly Safari TSR tarz.

Viet Nam Veteran 69-70, Troop "D" (AIR) 3/4 Cav. ,25th Inf. Div. CUCHI RVN. UH-1H Crew Chief of the "Pinball Wizard" 68-16224. Call Sign "CENTAUR".
Baby Huey is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:50 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC