Cutting out!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-05-2013, 07:27 PM   #1
Newb
 
Join Date: Jul 2013
Posts: 4
Cutting out!!

I just had a new 2.5L engine installed in my jeep cause the last one blow up. Everything was fine until the new engine was installed now after engine gets warm ill be running down the road and it will just cut out. I let off the gas and push gas it takes back off. Took back to dealer and they said it was crank shaft sensor. Replaced that and still doing it. Dealer dont know whats wrong. PLEaSE HELP!!!!

Getaway84 is offline   Quote
Old 07-06-2013, 11:24 PM   #2
jokerchief462

WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 9,695
YJ or TJ??

__________________
89 2.5 TBI, 4" RC lift, 1" Booms, SYE, Adams Driveshafts front and rear, Ford 8.8 with 4:88s, BFG 33X12.50X15, and a ton of other stuff.

AF Jeep Club Tail Number 184
jokerchief462 is offline   Quote
Old 07-07-2013, 04:18 PM   #3
Newb
 
Join Date: Jul 2013
Posts: 4
Tj
Getaway84 is offline   Quote
Old 07-08-2013, 02:34 PM   #4
Jeeper
 
Join Date: Jul 2013
Posts: 28
I would say take it to whoever installed it and demand they make it run right,
zracTA is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:02 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC