dead after hvac diagnostics - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 07-17-2012, 11:52 AM   #1
Join Date: Jul 2012
Posts: 1
sah9b is on a distinguished road
dead after hvac diagnostics


This post concerns a 99 TJ.

I have the age-old blower issue where certain blower speeds do not work (in my case all four). I've been trying to diagnose the problem according to instructions in various other posts. Yesterday I pulled out the blower motor, and it spins when a voltage is applied. I also pulled out the blower relay, which has been out since yesterday afternoon. I drove to work this morning with no issues, but when I left for lunch all electronics were dead, as in completely.

I had to disconnect the battery to get to the blower motor, but everything went back together nicely. The only thing that is not in its original place is the relay, but that couldn't kill the battery, could it? Anyhow, I'm stumped as to why it happened. Any insights would be much appreciated.
sah9b is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:49 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC
« Back

Enter your email address:

Delivered by FeedBurner