Electrical Problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-17-2011, 06:32 PM   #1
Newb
 
Join Date: Apr 2011
Posts: 1
Electrical Problem

I have a 99 Wrangler and every now and then when I hit a bump the wrong way my airbag light goes on and all other control signs(speedometer,gas,etc.)turns all the way to the left as though the car is off but is clearly running. Anyone have similar problems and if so would much appreciate some advice. Thanks

runibrow is offline   Quote Quick Reply
Old 04-17-2011, 06:55 PM   #2
President, ThumbJeeps

WF Supporting Member
 
sevenservices's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 3,947
welcome!

Sounds to me like water getting in somewhere. Check around behind the dash for any moisture. Not to say it couldn't be a loose connection somewhere, just something to check for.

__________________
-Chris
President, ThumbJeeps
CB Callsign "AirForce One"


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 4" RC (33x12.5) (15x8) 3:54 Gears
sevenservices is offline   Quote Quick Reply
Old 04-17-2011, 07:16 PM   #3
Jeeper
 
Scoob's Avatar
 
Join Date: Aug 2005
Location: Iowa
Posts: 1,790
Thats the same problem I had with my old 98 SE. If you smack the dash they would come back on
What you need to do is remove the gauge cluster and clean the pins where the wires meet the cluster. I cleaned the pins with contact cleaner and the put electrical grease in it and re-assembled. Only took a hour or so and I never had the problem again.
Its an easy fix if you just a little mech. inclined.
__________________
Scoob
Scoob is offline   Quote Quick Reply
Old 04-17-2011, 07:27 PM   #4
Jeeper
 
Join Date: Feb 2011
Posts: 117
had the same prob. with a 97 did the same as the above post and continued to applt dielec to any connector I could get to..no more problems.
mitymouse is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
94 Electrical Problem Captainframe YJ Tech Forum 2 05-01-2010 02:42 PM
1998 TJ Electrical Problem - Check Gages/Volt Meter SVRangerDad TJ Tech Forum 3 08-21-2009 07:56 PM
Electrical Problem Help popatop YJ Tech Forum 2 09-07-2008 01:53 PM
Electrical and Stall Problem - Please Help... jwh21236 TJ Tech Forum 13 08-27-2008 05:07 AM
tj electrical problem mick laporta TJ Tech Forum 17 03-24-2007 03:50 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:06 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC