Engine Problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-16-2010, 03:31 PM   #1
Jeeper
 
Join Date: Aug 2010
Posts: 36
Cool Engine Problems

I have a 1994 2.5l i4 jeep wrangler 5 speed standard transmission and its a great ride and everything.
I have 33 inch tires and a 4 inch lift, and its clean as hell.
Sometimes when im driving it will start to skip. It will run on all 4 and then start spuddering and start running on 2 and 3 cylinders. I have changed the o2 sensor and theres no egr valve but its still running bad. Theres no cat. converter on it but i dont think thats relevent.
Anybody have an idea on wtf is wrong?

Dance GvN Dance is offline   Quote Quick Reply
Old 08-16-2010, 03:57 PM   #2
Jeeper
 
GroundHawg's Avatar
 
Join Date: Apr 2010
Location: northeast ohio
Posts: 2,274
I'm assuming you've checked out the plugs and they're ok. I'm also assuming it's been tuned up before (plugs, wires, cap, etc.)

what I'd do is check for codes. do the ON OFF ON OFF trick. if I remember correctly, YJ's do indeed self diagnose.

couple things in my head right now on what's your culprit. crankshaft sensor, dirty injectors, or a bad fuel filter.

check those codes and see what she tells you, then tell us.

GroundHawg is offline   Quote Quick Reply
Old 08-19-2010, 12:26 AM   #3
Jeeper
 
Join Date: Aug 2010
Posts: 36
I had an ideah about the dirty filters and the fuel injected. And yes plugs are new and it's a pretty new engine so yes everything has been tuned up. I beleive tge crank sensor would mean it wouldn't run at so I'm kinda crossing that outta the problem. As for codes..?? WTF haha I have no clue about the codes BS. I'm only 15 but I know my way around an engine. I was also thinking that maybe a fuel injector is going bad. The exhaust is old and corroded from salt water and 173,000 miles so I'm guessing the exhaust may be a little plugged causing it to back up and make the o2 sensor read different giving the computor a bad read making the engine run the way it is. But it's getting scanned on Thursday, or tomorrow whenever you read this so I'll know soon enough thanks buddy keep up the input it helps alot
Dance GvN Dance is offline   Quote Quick Reply
Old 08-19-2010, 02:32 PM   #4
Jeeper
 
UABYJ94's Avatar
 
Join Date: Apr 2010
Location: Panama City
Posts: 210
Turn the ign to run off run off run then leave it in the run position after a few seconds the check engine light will start blinking the codes..
blink pause blink blink=12
blink blink blink pause blink blink blink=33
etc. Then if you have a manual(parts house have them for 25 bones) look up the codes it gives you. If you dont have the manual handy you can search the net for the codes very easily.
Note : If you dont have a/c you will get the 33 code everytime,dont worry about that one.
12 is battery disconnected in last 50 cranks...no big deal
55 will be the last one letting you know the self diagnosis is done.
UABYJ94 is offline   Quote Quick Reply
Old 08-19-2010, 04:12 PM   #5
Jeeper
 
Join Date: Aug 2010
Posts: 36
What would the codes do though?
I was also thinking that maybe the timing chain was off so the valves open and close just at the wrong time fouling out the plugs which would cause it not to run quite right.
Dance GvN Dance is offline   Quote Quick Reply
Old 08-19-2010, 05:04 PM   #6
Jeeper
 
GroundHawg's Avatar
 
Join Date: Apr 2010
Location: northeast ohio
Posts: 2,274
the codes will give you an idea as to where to start. as of right now we've just got symptoms, which could be alot of different things. generally the code will direct you towards a sensor. that sensor is reporting trouble with something it monitors, or the sensor itself malfunctions. like the code will be for the CPS. now you know to investigate there. if all seems well, the sensor is probably bad.

it beats just throwing parts at a vehicle.
GroundHawg is offline   Quote Quick Reply
Old 08-19-2010, 05:27 PM   #7
Jeeper
 
Join Date: Aug 2010
Posts: 36
Yeah it does haha. But throwing parts at a vehicle with 173,000 miles couldn't hurt haha. And thanks but it should be fixed by Saturday or Sunday hopefully. Also I need something to put on my steering column because its been broken apart before and that's also something that's supposed to be fixed at the shop. Is there anything I can buy to keep it from being broken again? Like a steel column or something?
Dance GvN Dance is offline   Quote Quick Reply
Old 08-19-2010, 08:49 PM   #8
Jeeper
 
UABYJ94's Avatar
 
Join Date: Apr 2010
Location: Panama City
Posts: 210
Now I'm confused as to why you asked for suggestions if you have no intentions of trying them..Ohh just read you are 15 I understand now,,,I must learn to proof read a lil better..
UABYJ94 is offline   Quote Quick Reply
Old 08-21-2010, 03:57 PM   #9
Jeeper
 
Join Date: Aug 2010
Posts: 36
I put up this forum right before we decided to put it in the shop. It's not because I'm 15 and didn't plan on doing it. I had every intention on fixing it myself but my dad insisted on bringing it to a shop to get it fixed.

Dance GvN Dance is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant Leak at Rear of 2.5 Engine KCrisp TJ Tech Forum 9 09-14-2010 11:08 AM
Engine problems calicocal TJ Tech Forum 4 08-19-2010 12:15 AM
Engine Light + Maintence problems Ericl TJ Tech Forum 2 08-16-2010 03:45 PM
05 blown engine tinworm TJ General Discussion Forum 10 10-27-2009 11:58 AM
the engine hoist saga continues... tiny terror Off-Topic 14 08-28-2009 02:02 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:39 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC