Ignition issue Help please - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-15-2012, 02:07 PM   #1
Newb
 
Join Date: Apr 2012
Posts: 4
Question Ignition issue Help please

I am working on my sons 89 YJ.
I turn the key to start it and it cranks and fires. Let off the key and it dies like the key was shut off.
I replaced the coil, the fuel pump and the fuel filter. I also pulled the Weber carb and cleaned it up. It is still doing the same thing.
I replace the ignition switch as well on the column.
I checked power to the coil with the key on and there is power.
I just ordered an ignition control module for it now. I am hoping there is something in there that has failed. Has anyone in here had this same issue? It is a 5 speed 258 ci. This has me stumped.

Mattdelman is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:28 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC