Ignition starter issue? Help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-15-2013, 07:25 AM   #1
Newb
 
Ruby1's Avatar
 
Join Date: Apr 2013
Posts: 3
Ignition starter issue? Help

Hey guys here's the problem... Have a 2003 TJ Rubicon 4.0. When I start her up, when cold, she just keeps clicking. If I stop and try again it seems to reset and starts right up. Not quite sure what's up with it...any ideas? Thanks in advance.

Ruby1 is offline   Quote
Old 10-15-2013, 10:54 PM   #2
Jeeper
 
R u s s's Avatar
 
Join Date: Jul 2013
Location: Snohomish County
Posts: 358
Images: 2
The soilinod in the starter contacts are getting bad. Just replace the starter.

R u s s is offline   Quote
Old 10-17-2013, 09:20 AM   #3
Jeeper
 
Shelby427's Avatar
 
Join Date: May 2011
Location: Lakeland FL and Hooversville PA
Posts: 2,193
Or you have the good old loose/ corroded connections at the battery.
__________________
97 Sahara, 74 Renegade, 72 CJ5, 55 Willy's (the Beast) Boss 302, 6:34 gearing, Bose 901 speakers.
God I miss that Jeep. Forgot the kinda Jeep, 80 SX4.
Shelby427 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:17 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC