Need help! I am getting a grinding sound when i brake in 4wd? What is it? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-26-2012, 10:53 AM   #1
Jeeper
 
beardown's Avatar
 
Join Date: Jun 2009
Posts: 563
Need help! I am getting a grinding sound when i brake in 4wd? What is it?

So I am getting this grinding sound when I brake in 4wd! It does not do it at all in 2wd only 4? Has anyone experienced this? Any idea what's going on? Also grinds when I go over bumps, hmmmmmm

beardown is offline   Quote Quick Reply
Old 02-26-2012, 02:31 PM   #2
The Bad Guy

WF Supporting Member
 
daggo66's Avatar
 
Join Date: May 2009
Location: NJ exile living in Baltimore
Posts: 22,055
It sounds as if you TC is not completely engaged. Are you in 4H or 4L? Which Wrangler?

__________________
Tom

"I've got two things in this world, my balls and my word and I don't break them for no one."
daggo66 is offline   Quote Quick Reply
Old 02-26-2012, 02:42 PM   #3
Jeeper
 
beardown's Avatar
 
Join Date: Jun 2009
Posts: 563
4 high, 93 yj, automatic 4 liter
beardown is offline   Quote Quick Reply
Old 03-03-2012, 09:17 PM   #4
Jeeper
 
beardown's Avatar
 
Join Date: Jun 2009
Posts: 563
Anybody?
beardown is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Were is the best place to get a new motor? pendletontn YJ Tech Forum 24 03-03-2012 10:44 PM
Which cat converter is my problem? zhero21 TJ General Discussion Forum 12 03-03-2012 08:27 PM
Installing a Incorrect 4.0 in a '01 TJ Dempsey Builders Corner 28 03-01-2012 08:03 PM
Currie Antirock, tell me my idea is dumb... netlohcs TJ General Discussion Forum 34 02-29-2012 04:59 PM
2012 JKU Arctic or Ruby? Help me decide! ChasmCrawler JK General Discussion Forum 14 02-27-2012 11:20 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:42 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC