speed sensor? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-25-2008, 07:57 PM   #1
Jeeper
 
Join Date: Jan 2008
Location: Illinois
Posts: 16
speed sensor?

I have a code that says i have a speed sensor malfunction? My service engine soon light is on, Four wheel drive won't go into gear and my speedo doesn't work either!! Any suggestions?

4byFour is offline   Quote
Old 01-25-2008, 09:51 PM   #2
delicate %$^&*@ flower

WF Lifetime Member
 
tiny terror's Avatar
 
Join Date: Feb 2006
Location: California
Posts: 14,753
The gurus need some more info about your jeep, I think.

tiny terror is offline   Quote
Old 01-25-2008, 10:09 PM   #3
Jeeper
 
Scoob's Avatar
 
Join Date: Aug 2005
Location: Iowa
Posts: 1,790
Quote:
Originally Posted by 4byFour View Post
I have a code that says i have a speed sensor malfunction? My service engine soon light is on, Four wheel drive won't go into gear and my speedo doesn't work either!! Any suggestions?
I think all these things are related to a problem inside your transfer case. Since it wont go into 4 wheel and the speedo gear is in the transfer case. Crack the case open and take a look see.
__________________
Scoob
Scoob is offline   Quote
Old 01-26-2008, 02:27 PM   #4
Jeeper
 
Gary1129's Avatar
 
Join Date: Jul 2007
Location: Bardwell Ky
Posts: 489
Quote:
Originally Posted by tiny terror View Post
The gurus need some more info about your jeep, I think.
Tru Dat.......just the lil stuff like the year.......The exact code its set(numbers).......its like bein blind and askin me which shirt is green.......g
__________________
Move along ...nothing ta see here


9.28.2008
Rest in Peace Gary
Gary1129 is offline   Quote
Old 01-26-2008, 06:41 PM   #5
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,632
The speed sensor is on the tail housing of the transfercase. Be sure its plugged in and tight.

Check the linkage for the transfer case. Make sure its all still together and moves. If its not engaging then there is an internal problem.
AzTJ is offline   Quote
Old 01-26-2008, 09:38 PM   #6
Jeeper
 
Join Date: Jan 2008
Location: Illinois
Posts: 16
Quote:
Originally Posted by 4byFour View Post
I have a code that says i have a speed sensor malfunction? My service engine soon light is on, Four wheel drive won't go into gear and my speedo doesn't work either!! Any suggestions?
It's a 99 tj wrangler 4.0 automatic

4byFour is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
throwing code, running poorly xtsniper0 TJ General Discussion Forum 16 03-08-2011 12:24 PM
Replacing speed sensor Silver YJ General Discussion Forum 1 09-04-2008 07:33 PM
YJ speed sensor ShaneCrozier YJ Tech Forum 0 07-02-2008 01:23 PM
P0501 - Vehicle Speed Sensor (VSS) Range/ Performance osbornl1 TJ Tech Forum 2 05-22-2007 05:32 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 11:33 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC