Speedometer problems - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-27-2007, 09:16 PM   #1
Newb
 
Join Date: Jul 2007
Posts: 8
Speedometer problems

Hey everyone. I was just hoping for some help. The speedometer on my 93 wrangler just stopped working. I bought a new speed sensor and put it on and it still doesn't work. I'm not quite sure what to do next. Any suggestions out there?

kulahpac is offline   Quote
Old 07-27-2007, 10:02 PM   #2
Jeeper
 
debruins's Avatar
 
Join Date: Feb 2007
Location: Needham Ma, Rangeley ME in the summer
Posts: 5,578
Send a message via AIM to debruins
does the odometer work?

debruins is offline   Quote
Old 07-28-2007, 10:46 AM   #3
Newb
 
Join Date: Jul 2007
Posts: 8
No... the odometer isn't working either... which makes it even more of a problem. I don't really know where to start now.
kulahpac is offline   Quote
Old 07-28-2007, 01:52 PM   #4
Jeeper
 
Tj Bunch's Avatar
 
Join Date: Mar 2007
Posts: 944
Try Taking it out and Clean The Conections for the Electrical everyone seems to say they are bad at getting Coroded (use only Electrical Cleaner NOTHING else) If that does not work you may need to replace cluster with a reman If you do get the #s off the back when it's out and Call Speed O Tach 1-800-442-4491 if that nuber does not work use this # 415-935-2040
They are here in Cali but should ship anywhere, Ask For Chris he's the Cluster Guru over there. I Buy alot from them and another place called AER In Los Angles Gm Clusters suck canal water from 99 up bad stepper motor design.

Thay will want Miles VIN# Probably Tire size Never done a jeep and of course name and payment type.

Greg
__________________
[2001 Wrangler 2.5 New Bumper and 2" BB-31x10.50-15 General AT2 on Soft 8 Steel Rims....
http://www.myjeepspace.com/TJ_BUNCH
Fresno Ca


Tj Bunch is offline   Quote
Old 08-08-2008, 12:08 PM   #5
Newb
 
Join Date: Jul 2007
Posts: 8
Hey everyone, I just wanted to close out this forum with a final answer for anyone else who has the same problem. I contacted Chris at Speed-O-Tach, and a week and $180 later the problem was taken care of.

Thanks for all the help.
kulahpac is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Clutch Problems and How I Resolved Them linz TJ Tech Forum 7 08-30-2014 06:36 AM
how to fix all vacume problems and how to locate the problems. Captaincoop1220 YJ Tech Forum 50 02-23-2013 12:19 PM
Speedometer Problems JEEPCHIK YJ Tech Forum 3 02-16-2009 09:52 AM
Color and # of stock Speedometer gear? Yellow 30? jonbugh TJ General Discussion Forum 5 03-11-2008 04:31 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 06:57 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC