Stumped - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-25-2013, 02:46 PM   #1
Newb
 
Join Date: Apr 2013
Posts: 3
Stumped

I have a 1993 Jeep Wrangler, I replaced the Fuel Pump several Months back and everything was fine until about a month ago. I can clearly hear the Pump Priming when I turn it on however now I have to use Primer in the Carb intake to get it to fire, once it fires it runs great and there are no issues there. I have taken out the Injectors and the plugs and thoroughly and carefully cleaned them both. I know it doe snot have a Standard Carb however I also removed the Carb intake and cleaned it up and down as well... I have checked all the lines to make sure there are no leaks as well.. I would greatly appreciated ANY help as I am STUMPED>. Also if I posted this in the wrong area I apologize....

CrashGear is offline   Quote
Old 08-25-2013, 03:26 PM   #2
Jeeper
 
Owen_TJ's Avatar
 
Join Date: Sep 2010
Location: Denver, CO
Posts: 4,465
Yeah, you'll get more help by posting in the YJ forum...this will get moved soon enough but good luck!!

I'm no help in this area unfortunately...

Owen_TJ is offline   Quote
Old 08-25-2013, 04:37 PM   #3
Newb
 
Join Date: Apr 2013
Posts: 3
Owen thanks, yeah I don't think I have NOT ripped out one thing trying to resolve this issue.... Blowing my mind....
CrashGear is offline   Quote
Old 08-25-2013, 05:33 PM   #4
Moderator

::WF Moderator::
 
harleydragon's Avatar
 
Join Date: Jul 2012
Location: south georgia
Posts: 3,927
could be fuel pressure regulator
harleydragon is offline   Quote
Old 08-30-2013, 03:06 PM   #5
Newb
 
Join Date: Apr 2013
Posts: 3
OK so I changed the Fuel Pressure Regulator today as well... Still doing the same thing.... The manufacturer of the Fuel Pump said it is an air leak somewhere in the line when it's priming but this sounds like BC to me... I have checked that line 10 times or more and there are no leaks... I am stumped and have no further ideas as to where to look.... Any ideas would help......
CrashGear is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:51 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC