turn signal problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-29-2010, 12:48 PM   #1
Jeeper
 
Join Date: Aug 2010
Location: Hewitt tx
Posts: 60
turn signal problem

89 yj Laredo. Got rained in the other day, now my turn signals no longer flash. They activate but the light does not flash back off. Anybody have this problem or any suggestions.

89jeepster is offline   Quote Quick Reply
Old 08-30-2010, 08:04 AM   #2
Jeeper
 
Join Date: Aug 2010
Location: Hewitt tx
Posts: 60
?

89jeepster is offline   Quote Quick Reply
Old 08-30-2010, 08:07 AM   #3
Jeeper
 
drivebytruckerz's Avatar
 
Join Date: Apr 2010
Posts: 2,011
Change out the fuse. Good place to start.
__________________
"Not all who wander are lost.."

2000 TJ Sport 4.0
2005 WK (Grand Cherokee) Limited 5.7 HEMI


(OIF '05-'06 Mahmudiyah, Scania)
drivebytruckerz is offline   Quote Quick Reply
Old 08-30-2010, 08:08 AM   #4
Deaky

WF Supporting Member
 
Fweaky's Avatar
 
Join Date: Aug 2009
Location: Central Virginia
Posts: 2,202
Images: 18
Check the bulbs ... will either side flash?
__________________
Nothing is foolproof to a sufficiently talented fool.
Fweaky is offline   Quote Quick Reply
Old 08-30-2010, 09:18 AM   #5
Jeeper

WF Supporting Member
 
Got_Mud?'s Avatar
 
Join Date: Mar 2010
Location: Charlottesville, VA
Posts: 347
Sounds like the flasher relay got wet - if they light but don't blink... under the dash on the left side kickplate is where mine is... Cheap and easy way to test - activate your hazards - they work off a different flasher. That'll test the bulbs. If they work, then swap the two flasher relays. If the turn signals now work, buy a new flasher... under $10 anywhere.. (ok, any place that sells auto parts - LOL)

Good luck!
__________________
In dog beers, I've only had one.....
Got_Mud? is offline   Quote Quick Reply
Old 08-31-2010, 07:07 AM   #6
Jeeper
 
Join Date: Aug 2010
Location: Hewitt tx
Posts: 60
Hey guys thanks for the answers think I got my question answered. I'll check it this afternoon. It sounds right because both of them are doing it, but the hazard lights still flash. Love this sight, I was about to start tearing my steering wheel apart. Thanks again
89jeepster is offline   Quote Quick Reply
Old 08-31-2010, 01:27 PM   #7
Jeeper

WF Supporting Member
 
Got_Mud?'s Avatar
 
Join Date: Mar 2010
Location: Charlottesville, VA
Posts: 347
but we could all be wrong, too

Let us know

__________________
In dog beers, I've only had one.....
Got_Mud? is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird headlight/turn signal electrical problem Got_Mud? YJ Tech Forum 6 12-17-2011 07:20 PM
Turn signal problem JimQ Off-Topic 1 08-28-2010 03:48 PM
Picture request: Turn signal arm 95muddyYJ YJ General Discussion Forum 0 08-30-2009 01:50 PM
turn signal / radio problem nomik4u TJ Tech Forum 5 12-20-2008 12:55 PM
Turn Signal Problem** Johntom TJ Tech Forum 1 08-15-2008 05:01 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:23 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC