Weber car issues - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-06-2013, 01:30 AM   #1
Jeeper
 
Unity04073's Avatar
 
Join Date: Jun 2013
Posts: 15
Weber car issues

I have a 4.2 with a weber 2 bl card , I am blowing black smoke and have tried to tune with no luck any suggestions would help

Unity04073 is offline   Quote
Old 07-06-2013, 10:57 PM   #2
Jeeper
 
bc3_Jeep's Avatar
 
Join Date: Nov 2010
Location: NE corner of Iowa
Posts: 1,726
Sounds more like a float issue..... have you checked the float?

OR...... stuck choke...... is the choke disengaging???

OR......gasket breach from the bowl to the throttle body....
__________________
"For Gawd's sake, put a RELAY in there or you could burn the whole damn Jeep to the ground" ...this quote brought to you by people who do not understand the law.....Kirchoff's, Ohm's, or Faraday's.
Violation of KISS shall always ring false in TRUE engineering. - ME___
Had 75CJ5, 89YJ, 93YJ. Have 82CJ7 & 95YJ____Not one burnt yet due to lack of relays.
bc3_Jeep is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:49 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC