engine noise - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-23-2014, 11:21 AM   #1
Jeeper
 
Join Date: Nov 2011
Location: pa
Posts: 24
engine noise

i have a jeep jku ...and under exceration there is a loud pinging noice i hear it through all gears and when it is under load( going uphill) it gets worse....anyone have any sugestions im taking it to the dealer on thursday, but they seem to have no idea....could it be timing,pre detionation, or somthing else
thanks

pozzer145 is offline   Quote Quick Reply
Old 05-08-2014, 08:22 PM   #2
Jeeper
 
dewey7015's Avatar
 
Join Date: Jan 2014
Posts: 28
any updates? my 2014 does the same thing! 10000 miles on mine..

dewey7015 is offline   Quote Quick Reply
Old 05-08-2014, 10:08 PM   #3
Jeeper
 
jgreene0717's Avatar
 
Join Date: May 2013
Location: Wetumpka, AL.
Posts: 44
Try running 89 octane or better. Also a different gas station might be the fix. It's sounds like pre detonation.
jgreene0717 is offline   Quote Quick Reply
Old 05-09-2014, 05:15 AM   #4
Jeeper
 
Join Date: May 2011
Posts: 2,385
I wonder if the knock sensor is bad and it hasn't thrown a code.
demarpaint is online now   Quote Quick Reply
Old 05-09-2014, 05:38 AM   #5
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 35,330
My 07 pinged uphill/hard acceleration. Techron helped a lot. Cured running 93 octane/SC perf tune.

Also check the spot welds on the exhaust heat shield.
__________________
2007 Rubicon/Rock Krawler triple rate 2.5" coils/RK rear TB w/ a teraflex raised bracket/Rancho 9000 31/32XL shocks/Synergy flipped draglink,ball joints,tie rod /Hankook MT 315-75-16 on Level 8 ZX's/Rancho geo brackets/Ruff stuff uppers/Fox ATS stabilizer/Adams front DS/Artec front armor w/ Currie upper bushings/Rancho cat back exhaust.

Lifting your JK? Read this!!



Click HERE to become a WranglerForum Supporting Member!
kjeeper10 is online now   Quote Quick Reply
Old 05-10-2014, 06:09 AM   #6
Jeeper
 
dewey7015's Avatar
 
Join Date: Jan 2014
Posts: 28
I certainly don't want to start another gas thread, or hijack this one.
I am in the camp of: if I pay $34,000, and I need to run 93 octane, Chrysler/fiat will have a used wrangler on their hands. No way the sticker says run 87....87 it is.
dewey7015 is offline   Quote Quick Reply
Old 05-10-2014, 06:15 AM   #7
Jeeper
 
Join Date: May 2011
Posts: 2,385
Quote:
Originally Posted by dewey7015 View Post
I certainly don't want to start another gas thread, or hijack this one.
I am in the camp of: if I pay $34,000, and I need to run 93 octane, Chrysler/fiat will have a used wrangler on their hands. No way the sticker says run 87....87 it is.
You're right, if it is pinging with 87 Octane gas and the vehicle was designed to run on 87 Octane have the dealer check it out. It should run problem free on 87 Octane if it calls for it.
demarpaint is online now   Quote Quick Reply
Old 05-10-2014, 10:45 AM   #8
Jeeper
 
dewey7015's Avatar
 
Join Date: Jan 2014
Posts: 28
dealer told me that it was "normal, because they lean out the engines to get better gas mileage" He didn't really have an answer for me when I asked what happens in 100,000 miles, and i need some severe engine work...just looked at me.
I will be hanging on to this jk, until i can justify taking the hit to trade for the deisel! lol
dewey7015 is offline   Quote Quick Reply
Old 05-10-2014, 10:52 AM   #9
Junior Member
 
Join Date: Apr 2014
Posts: 830
Sounds like your lugging the engine, try downshifting.
mhicanders is offline   Quote Quick Reply
Old 05-10-2014, 11:29 AM   #10
Supporting Member

WF Supporting Member
 
danrb's Avatar
 
Join Date: Nov 2012
Location: VA
Posts: 896
Mine started doing it with the lift and bigger tires. I've had to change my shift points. I use to shift to sixth around 50. I noticed a lot of pre ignition after the tires and lift. Now I shift latter around 60 into sixth. Guess regearing will get it back to where I think it should be.
__________________
2013 JKUR. Rock Krawler 3.5 X-Factor, Nitto Trail Trappler 35x12.5x17, ACE Rock Sliders, Poison Spyder Brawler MID Front Bumper with Brawler Bar, ENGO E10000S Electric Winch, ACE Engineering JK Pro Series Rear Bumper with Tire Carrier, JW Speaker 8700, Dually Fog lights and sPOD
danrb is online now   Quote Quick Reply
Old 05-10-2014, 12:14 PM   #11
Jeeper
 
Join Date: Nov 2011
Location: pa
Posts: 24
i have tried alot of different things 93 octaine, fuel treatment only sunoco gas, but nothing worked i had it in 2 weeks ago and they did an oil comsumption test on it and it was burning oil..in 500 miles it was down 1/4 of a quart(when they origanlly drained the oil it was 1.5 quarts low in 2000 miles) they founf a bad ring seal in the 6th piston..but that hasnt fixed it yet...it goes back in on tuesday and now they might just replace the entire motor...ill let u all know how i make out

pozzer145 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 12:27 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC