finally was able to. - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-15-2014, 03:53 PM   #1
Jeeper
 
dyzard's Avatar
 
Join Date: Mar 2013
Posts: 27
finally was able to.

Take out my new jeep had it for a month and a half got some good mud on it got some rocks and good mud. No damage that I can tell yet except messed up my alignment, not terribly just slightly, but I get a dragging feeling when I go now feels like brakes are constantly applied, and the ebs bas light stays on as well as the esp light comes on until I turn it off, thinking I just got a bunch of mud on my brakes still haven't cleaned it off took it out last night so still waking up but it's on the to do list to get my engine compartment and Windows wheels and undercarriage washed up hoping it's just mud stuck up in it

dyzard is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 08:02 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC