Has This Malfunction Happened To Anyone Else? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-14-2007, 12:04 PM   #1
Newb
 
RenoosRemoob's Avatar
 
Join Date: Jan 2007
Posts: 8
Has This Malfunction Happened To Anyone Else?

We got our new 2007 Jeep Wrangler Unlimited X with the S Package towards the end of November and we absolutely love it.

Over the Christmas holidays, our Malfunction Indicator Light went on a couple of times. At first, I thought our gas cap might just be loose or wondered if we might have purchased some poor quality fuel (since I had just gone to a source I don't normally use). But, then, the light started flashing so I checked the manual in the glove box and the pdf owners manual I got off another website (Project JK.com). Both said the malfunction indicator light may flash to alert serious conditions that could lead to immediate loss of power or serve catalytic converter damage. The vehicle should be serviced aSAP if this occurs. So, we didn't drive it anymore and called the dealership, who said we should call the 1-800 line for towing service to the dealership for service, which we did.

They made one attempt to fix it and gave it back to us. On the way home from the dealership, the light started flashing again, so we took it right back. Well, our dealer has how had our new jeep for 2 full weeks and they still don't know what is causing the problem. At first, they thought it was something wrong with the #6 valve but they decided against that and check everything they thought could be related. Still no answers so they've called the DC/Jeep hotline seeking ideas to help guide them.

Have any of you experienced a similar problem with your brand new JK? I would appreciate any information you may be able to share with me.

Thanks.

RenoosRemoob is offline   Quote
Old 01-22-2007, 08:29 PM   #2
Jeeper
 
Join Date: May 2005
Location: Lake Winola, PA
Posts: 264
my gas cap indicator came on and the dealer fixed it but it came on again the next day along withthe check engine light and i took it back and they had it fot the whole day but it hasent happend since

__________________
07 Unlimited Rubi,Rock Krawler,RCV,Reid,RiverRaider,TenFactory,PolyPerfor mance,Yukon,Fox
BeerMonkeY is offline   Quote
Old 02-06-2007, 11:06 PM   #3
Newb
 
RenoosRemoob's Avatar
 
Join Date: Jan 2007
Posts: 8
We Finally Got It Back!

I want to be as quick to acknowledge our problem has been fixed as I was to express our frustration about our MIL.

The dealership called us yesterday and said they were getting ready to do something [I don't recall what he used as a lead-in], and then someone asked if they had done a fuel sample. Apparently, they had not, so they did and found a huge amount of water in the tank. He said they had a coke bottle sitting on their desk that has a little bit of gasoline and a huge amount of water that they said came right out of our injector rail.

I'm no mechanic, but as I understand it, the pipe that supplies pressurized fuel to all of the fuel injectors is called the fuel rail. It is supplied with pressurized fuel by the fuel pump and it is capable of opening and closing many times per second. The injectors are mounted in the intake manifold so they spray fuel directly at the intake valves.

He said they needed to clean out all of the bad gas from the gas tank and replace it with new fuel. This is mentioned several times in my pdf file owners manual, relating to the malfunction indicator light:
• Certain conditions such as a loose or missing gas cap, poor quality fuel, etc. may illuminate the light after engine start.
• Poor quality gasoline can cause problems such as hard starting, stalling and hesitations. If you experience these symptoms, try another brand of gasoline before considering service for the vehicle.

So, hopefully, this will put an end to our MIL problem for a very long while. We are extremely happy to have our JK back in our possession after 35 very long days.
RenoosRemoob is offline   Quote
Old 11-17-2013, 09:38 PM   #4
Jeeper
 
Join Date: Jan 2013
Posts: 27
nope
mtehan is offline   Quote
Old 11-17-2013, 11:50 PM   #5
Jeeper
 
Join Date: Feb 2013
Posts: 1,935
Quote:
Originally Posted by mtehan View Post
nope
We've been waiting 7 years for your response.
legitposter is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just got a wrangler! It broke down not sure what happened! Go_Wrangler General Jeep Discussion 12 01-02-2009 03:03 PM
Throttle malfunction!!!! txag02 JK Tech Forum 18 08-23-2007 11:26 PM
What Happened To ROF steamnsteel Off-Topic 1 02-04-2007 05:33 PM
What happened to WF?!?!?! deverhart General Jeep Discussion 50 12-14-2006 09:48 AM
Admin - What happened? Scout Off-Topic 203 11-28-2006 06:49 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:14 PM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC