JK troubleshooting HELP! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-25-2009, 04:16 PM   #1
Newb
 
Join Date: Apr 2009
Posts: 1
JK troubleshooting HELP!

I have a 2008 jeep Wrangler unlimited 6 speed. The check engine light and 'esp off' light comes on. The dealer can't find the problem. Once they come on, the engine will hesitate. Turning the ESP switch doesn't have any affect. I am wondering if anyone has had this problem.

langmike is offline   Quote Quick Reply
Old 04-25-2009, 09:28 PM   #2
Jeeper
 
iamagolfspaz's Avatar
 
Join Date: Nov 2006
Location: Palm Desert
Posts: 1,113
Send a message via Yahoo to iamagolfspaz
I had the check engine light and it was just the gas cap.

iamagolfspaz is offline   Quote Quick Reply
Old 04-25-2009, 09:57 PM   #3
Jeeper
 
bblustang90's Avatar
 
Join Date: Mar 2009
Location: hawaii
Posts: 32
I had one also dealer said was the cam shaft sensor they replaced it . but i dont recall it running rough while it was on.
bblustang90 is offline   Quote Quick Reply
Old 04-25-2009, 10:37 PM   #4
Member
 
Join Date: Mar 2009
Location: Upstate/Eastern NY
Posts: 1,960
Send a message via AIM to thaduke2003
A good start would be to find out what CEL code it's throwing. Then maybe we can start to help Otherwise, throw darts at a diag chart Equally useful.
Check for loose connections, things that are obviously broken.
Is the rig modded?
Did you change anything right before this started?
MIGHT be TPS, going by what you're telling me, but do NOT quote me on that! Mark W.
thaduke2003 is offline   Quote Quick Reply
Old 04-26-2009, 08:06 PM   #5
Jeeper
 
Join Date: May 2005
Location: Lake Winola, PA
Posts: 264
mindid that but also had the abs light on and it was a wheels speed sensor at one of the rear wheels
__________________
07 Unlimited Rubi,Rock Krawler,RCV,Reid,RiverRaider,TenFactory,PolyPerfor mance,Yukon,Fox
BeerMonkeY is offline   Quote Quick Reply
Reply

Tags
2008 , troubleshooting , tsb

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch troubleshooting help Kurogo YJ Tech Forum 5 08-27-2007 03:01 PM
Troubleshooting p0442 elkhound TJ Tech Forum 0 08-01-2007 01:31 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:09 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC