NavTool - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-17-2014, 04:19 PM   #1
Jeeper
 
Join Date: Apr 2014
Posts: 41
NavTool

I have a 2014 JKU. I just purchased a NavTool interface so I could install a BU camera. The contents in the NavTool box consisted of 1-the module. 2-the main harness. 3-a video pigtail with a dark blue & a yellow wire with small terminals on the ends that appear should be inserted into a plastic plug. This video pigtail was loose in the box. There were no instructions provided and NavTool has been of no help with information as to where to connect this video pigtail. Any help will be greatly appreciated.

Jeepsforkeeps is offline   Quote Quick Reply
Old 04-17-2014, 04:59 PM   #2
Jeeper
 
cc4005's Avatar
 
Join Date: Jun 2012
Posts: 231
Looks like installation manuals are on their website.
JEEP NavTool video interfaces

http://www.navtool.com/manual_CANBOX+MYGIG.pdf

cc4005 is offline   Quote Quick Reply
Old 04-17-2014, 05:15 PM   #3
Jeeper
 
Join Date: Apr 2014
Posts: 41
Thanks cc4005 but that's my problem. Nothing on their website matches what I received from them. I'm hoping someone on here has had this same issue and was able to resolve it. My emails to NavTool are going unanswered. Now thinking LockPick V5 would have been a better option.
Jeepsforkeeps is offline   Quote Quick Reply
Old 04-17-2014, 06:16 PM   #4
Jeeper
 
chargermop's Avatar
 
Join Date: Jan 2014
Posts: 1,476
Quote:
Originally Posted by Jeepsforkeeps View Post
I have a 2014 JKU. I just purchased a NavTool interface so I could install a BU camera. The contents in the NavTool box consisted of 1-the module. 2-the main harness. 3-a video pigtail with a dark blue & a yellow wire with small terminals on the ends that appear should be inserted into a plastic plug. This video pigtail was loose in the box. There were no instructions provided and NavTool has been of no help with information as to where to connect this video pigtail. Any help will be greatly appreciated.
Sounds like they sent the wrong one, what your describing sounds like the one for an older REC NAV unit.
chargermop is offline   Quote Quick Reply
Old 04-17-2014, 06:28 PM   #5
Jeeper
 
chargermop's Avatar
 
Join Date: Jan 2014
Posts: 1,476
I am guessing it looks like this?
chargermop is offline   Quote Quick Reply
Old 04-17-2014, 07:23 PM   #6
Jeeper
 
Join Date: Apr 2014
Posts: 41
I agree chargermop. I think they sent the wrong or an incomplete kit and for three days haven't answered my emails. It looks nothing like your pix. That harness, or something similar, is what I expected. What I got was one short harness with three plugs. It consists of one end which plugs into the back of the radio, one end that the OEM radio plug goes into & a third end that plugs into the NavTool module. No where to plug in a video camera. The short video pigtail that was loose in the box is my dilemma. Where do the two wires on the end opposite the RCA type video plug connect? It appears from pictures on the web that they should be connected to the plug that plugs into the module. It isn't & won't. They couldn't answer my question on the phone and told me to email their tech support. I did, getting no response. A simple answer or simple diagram from them would resolve this quickly.
Jeepsforkeeps is offline   Quote Quick Reply
Old 04-17-2014, 07:43 PM   #7
Jeeper
 
Join Date: Oct 2012
Posts: 53
when I was installing my NavTool I got fast support via email techsupport@navtool.com
wrangler4eva is offline   Quote Quick Reply
Old 04-17-2014, 08:40 PM   #8
Jeeper
 
Join Date: Apr 2014
Posts: 41
Click image for larger version

Name:	ForumRunner_20140417_213905.jpg
Views:	196
Size:	66.6 KB
ID:	999193
Jeepsforkeeps is offline   Quote Quick Reply
Old 04-17-2014, 09:10 PM   #9
Jeeper
 
Join Date: Apr 2014
Posts: 41
Hopefully the picture I Posted will help.
wrangler4eva, how long did it take for them to get back to you by email? The odd thing is, before I bought this I did a "chat" with them, asking if this would work on my 2014. They replied back instantly. Once I paid for it there has been zero response from them to my emails. As I said, I emailed their tech support and also their general email & nothing.....
Jeepsforkeeps is offline   Quote Quick Reply
Old 04-17-2014, 11:42 PM   #10
Jeeper
 
Join Date: Oct 2012
Posts: 53
Quote:
Originally Posted by Jeepsforkeeps View Post
Hopefully the picture I Posted will help.
wrangler4eva, how long did it take for them to get back to you by email? The odd thing is, before I bought this I did a "chat" with them, asking if this would work on my 2014. They replied back instantly. Once I paid for it there has been zero response from them to my emails. As I said, I emailed their tech support and also their general email & nothing.....
it's same one I got, they reply within minutes
wrangler4eva is offline   Quote Quick Reply
Old 04-18-2014, 12:38 AM   #11
Jeeper
 
Join Date: Apr 2014
Posts: 41
Quote:
Originally Posted by wrangler4eva View Post
it's same one I got, they reply within minutes
Thanks. That's encouraging. Where did you connect the two leads on the video pigtail. I appreciate your help.
Jeepsforkeeps is offline   Quote Quick Reply
Old 04-18-2014, 04:50 AM   #12
Jeeper
 
OverFueled's Avatar
 
Join Date: Oct 2013
Location: Pepperell, MA
Posts: 100
I had the same problem. I got mine on monday and it took all week to get the info out of them. There are NO instructions. Only guestions. If you have a 730N the yellow is the positive goes on pin 3 of the empty connector in the back of the radio. The black is the negative goes on pin 4. Mine looks the same as your NavTool.
__________________
I drive a Jeep because it is an
"open invitation to live life to the fullest"
2014 JK Rubicon X Mods 275/65/20 Nitto Terra Grabblers / Black Rino 20" x 9.
TrukLights with Inspired Engineering LED Fog Lights
Installed Grill inserts, S-POD, A.E.V. 2.5 Lift/corrections brackets. MYGig Lock Pick.
OverFueled is offline   Quote Quick Reply
Old 04-18-2014, 08:22 AM   #13
Jeeper
 
Join Date: Apr 2014
Posts: 41
Quote:
Originally Posted by OverFueled View Post
I had the same problem. I got mine on monday and it took all week to get the info out of them. There are NO instructions. Only guestions. If you have a 730N the yellow is the positive goes on pin 3 of the empty connector in the back of the radio. The black is the negative goes on pin 4. Mine looks the same as your NavTool.
This is exactly the info I needed. Thanks. I'm about to go connect it up. I'll post the results. I'll have to say their customer service seems to be lacking. A very simple schematic included would save a lot of time & trouble....
Jeepsforkeeps is offline   Quote Quick Reply
Old 04-18-2014, 11:57 AM   #14
Jeeper
 
OverFueled's Avatar
 
Join Date: Oct 2013
Location: Pepperell, MA
Posts: 100
not to mention they do not speak english well. I hope I gave the correct info. Let me know.
__________________
I drive a Jeep because it is an
"open invitation to live life to the fullest"
2014 JK Rubicon X Mods 275/65/20 Nitto Terra Grabblers / Black Rino 20" x 9.
TrukLights with Inspired Engineering LED Fog Lights
Installed Grill inserts, S-POD, A.E.V. 2.5 Lift/corrections brackets. MYGig Lock Pick.
OverFueled is offline   Quote Quick Reply
Old 04-18-2014, 01:42 PM   #15
Jeeper
 
Join Date: Apr 2014
Posts: 41
Thanks for everyone's response but I sent it back! Not comfortable with the way it connected, especially the video pigtail to the radio. Should have a plug to go into the radio for the video, not two bare metal ends to plug onto the radio pins. Also slow or no response to questions etc., etc. Hopefully Lockpick V5 will be better. Any comments on that?
Jeepsforkeeps is offline   Quote Quick Reply
Old 04-18-2014, 02:25 PM   #16
Jeeper
 
Join Date: Oct 2012
Posts: 53
you should have connector back of the radio with few wires and pigtail goes into that connector
wrangler4eva is offline   Quote Quick Reply
Old 04-18-2014, 02:31 PM   #17
Aussie in Exile

WF Supporting Member
 
tomba's Avatar
 
Join Date: Feb 2014
Location: PWC, NOVA
Posts: 462
Images: 3
Quote:
Originally Posted by OverFueled View Post
I had the same problem. I got mine on monday and it took all week to get the info out of them. There are NO instructions. Only guestions. If you have a 730N the yellow is the positive goes on pin 3 of the empty connector in the back of the radio. The black is the negative goes on pin 4. Mine looks the same as your NavTool.
Subscribed! I planned on going the Navtool route as soon as I get back the USA and get to pick up my JKRUX! I also have the 730N...no problems with it? My background is electronics so I'm good with pin outs...

I assume the RCA that pins to 3+4 is the video feed for the back up camera?
__________________
Current Jeeps:
1998 Jeep XJ- SOLD!
2014 Granite JKU Rubicon X 730n/ Dual Top/ 6SP Manual
tomba is offline   Quote Quick Reply
Old 04-18-2014, 05:18 PM   #18
Jeeper
 
OverFueled's Avatar
 
Join Date: Oct 2013
Location: Pepperell, MA
Posts: 100
Quote:
Originally Posted by tomba View Post
Subscribed! I planned on going the Navtool route as soon as I get back the USA and get to pick up my JKRUX! I also have the 730N...no problems with it? My background is electronics so I'm good with pin outs...

I assume the RCA that pins to 3+4 is the video feed for the back up camera?
Yes it is. You can also install a (front) camera if you want. to the NavTool.

I taped the pins to cover them I also taped the cord to the back of the radio as well.
__________________
I drive a Jeep because it is an
"open invitation to live life to the fullest"
2014 JK Rubicon X Mods 275/65/20 Nitto Terra Grabblers / Black Rino 20" x 9.
TrukLights with Inspired Engineering LED Fog Lights
Installed Grill inserts, S-POD, A.E.V. 2.5 Lift/corrections brackets. MYGig Lock Pick.
OverFueled is offline   Quote Quick Reply
Old 04-19-2014, 10:21 PM   #19
Supporting Member

WF Supporting Member
 
imgoin's Avatar
 
Join Date: Dec 2013
Posts: 9
I purchased the navtool also. Did the purchase on line, they instantly pulled the funding. Then sent me an email that it would be 6 weeks on delivery. After a 7 week wait it showed up. Mean while I had downloaded there instruction manual, studied it and decided, there instructions are like a dog chasing its tail non stop.
__________________
2006 Liberty CRD
2009 JKU Rubicon
2013 JK Rubicon
imgoin is offline   Quote Quick Reply
Old 04-22-2014, 07:29 PM   #20
Jeeper
 
OverFueled's Avatar
 
Join Date: Oct 2013
Location: Pepperell, MA
Posts: 100
I am sending mine back just cant get it working and now my voice command stopped working because of it.

These guys just dont know what they are doing.
__________________
I drive a Jeep because it is an
"open invitation to live life to the fullest"
2014 JK Rubicon X Mods 275/65/20 Nitto Terra Grabblers / Black Rino 20" x 9.
TrukLights with Inspired Engineering LED Fog Lights
Installed Grill inserts, S-POD, A.E.V. 2.5 Lift/corrections brackets. MYGig Lock Pick.
OverFueled is offline   Quote Quick Reply
Old 04-22-2014, 07:31 PM   #21
Jeeper
 
OverFueled's Avatar
 
Join Date: Oct 2013
Location: Pepperell, MA
Posts: 100
jeeps for keeps Did you get a refund? I sending mine back as well.
__________________
I drive a Jeep because it is an
"open invitation to live life to the fullest"
2014 JK Rubicon X Mods 275/65/20 Nitto Terra Grabblers / Black Rino 20" x 9.
TrukLights with Inspired Engineering LED Fog Lights
Installed Grill inserts, S-POD, A.E.V. 2.5 Lift/corrections brackets. MYGig Lock Pick.
OverFueled is offline   Quote Quick Reply
Old 04-22-2014, 07:44 PM   #22
Jeeper
 
Join Date: Apr 2014
Posts: 41
Quote:
Originally Posted by OverFueled View Post
jeeps for keeps Did you get a refund? I sending mine back as well.
It was supposed to arrive back at NavTool today. I'm not where I can check the tracking until tomorrow. I'm curious as to how long it will take them to credit my CC. After waiting a week for an RMA number I gave up and called them. The person wanted to know why I wanted to return it then put me on hold for a long time. Finally came back on the phone & said just send it to his attention. Still no RMA. I've not been comfortable with this entire situation since I first ordered it.....
Jeepsforkeeps is offline   Quote Quick Reply
Old 04-23-2014, 04:37 PM   #23
Jeeper
 
OverFueled's Avatar
 
Join Date: Oct 2013
Location: Pepperell, MA
Posts: 100
Yes me to. I just got off the phone with Eddie and George was aksked a bunch of questions. Like what is wrong with me for ever thinking I want to return there piece of crap with no instructions of how to install that never worked, could never get in touch with them after the order, would not awnser emails.

And then ask me why I want to return it.!!!!!!! If a bullet would travel that far I would start shooting now.

They told me 10 business days after they get it back. They would credit my cc back.
__________________
I drive a Jeep because it is an
"open invitation to live life to the fullest"
2014 JK Rubicon X Mods 275/65/20 Nitto Terra Grabblers / Black Rino 20" x 9.
TrukLights with Inspired Engineering LED Fog Lights
Installed Grill inserts, S-POD, A.E.V. 2.5 Lift/corrections brackets. MYGig Lock Pick.
OverFueled is offline   Quote Quick Reply
Old 04-23-2014, 08:51 PM   #24
Jeeper
 
KPM171's Avatar
 
Join Date: Jun 2012
Location: Washington, DC
Posts: 89
Just got off tech support chat w/ NAVTool. Jeepsforkeeps, I got the same pieces in my box from NAVTool and thought I was missing parts. When I asked for instructions, I was told repeatedly to just plug it in and it would work. And that the buttons on the device don't do anything. I finally found out that they have another 22-pin harness that you can buy for $25 that has 2 RCA video lines coming out.

I wanted to go the LockPick route, but was told by the staff at LockPick that it would never work w/ a manual transmission.
__________________
2013 Billet Silver Unlimited Rubicon (My Build)
6-Spd, 4.10's, ARB Bull Bar, XRC X20 Winch, sPOD, Rigid Industry Floods, onboard-air, & way more comfortable than a Wrangler has any business being!

Retired but never forgotten

2005 Wrangler TJ
KPM171 is offline   Quote Quick Reply
Old 04-23-2014, 09:10 PM   #25
Aussie in Exile

WF Supporting Member
 
tomba's Avatar
 
Join Date: Feb 2014
Location: PWC, NOVA
Posts: 462
Images: 3
Quote:
Originally Posted by KPM171 View Post
Just got off tech support chat w/ NAVTool. Jeepsforkeeps, I got the same pieces in my box from NAVTool and thought I was missing parts. When I asked for instructions, I was told repeatedly to just plug it in and it would work. And that the buttons on the device don't do anything. I finally found out that they have another 22-pin harness that you can buy for $25 that has 2 RCA video lines coming out.

I wanted to go the LockPick route, but was told by the staff at LockPick that it would never work w/ a manual transmission.
Im in the same boat. I want to use Lockpick but have a manual. I called lockpick and they told me they do not have the programming right for the manual...something about the way it picks up putting the Jeep in reverse to activate the camera. They seemed really interested in my idea of turning the camera on manually....I was planning to use an unused A-pillar switch to turn it on and off. They told me "we don't recommend it" but would love to know how it works for me.

Anyone here try NAVTV?
__________________
Current Jeeps:
1998 Jeep XJ- SOLD!
2014 Granite JKU Rubicon X 730n/ Dual Top/ 6SP Manual
tomba is offline   Quote Quick Reply
Old 04-23-2014, 10:18 PM   #26
Jeeper
 
Join Date: Apr 2014
Posts: 41
Lockpick

Too bad about the manual transmission/Lockpick situation. Maybe they'll have something soon. Just finished the lockpick install on my 2014 JKU auto and it works perfectly. TOTALLY plug & play. 15 minute install not counting the camera. Works with the steering wheel buttons. Multiple audio & video inputs & outputs plus 12v outputs. Shipped 2nd day priority mail. The whole Navtool situation was a total fiasco for me. To repeat about Navtool: where are the specific instructions for the JKU??? Why didn't they tell me about the "other" harness during the four phone calls to them? Why didn't they answer my emails and on & on?
Jeepsforkeeps is offline   Quote Quick Reply
Old 04-23-2014, 10:44 PM   #27
Jeeper
 
Join Date: Oct 2012
Location: North Tahoe Area
Posts: 46
Navtool

I have a 2013 JKU and I'm having a simular problem with Navtool. I got the little blue box called Mygig cam kit which included a harness and camera cable with absolutely no instructions or schematics. My phone calls were futile. I finally found some information on various other forums. The back up camera cable is plugged in on the back of the radio/nav unit pins 3 & 4(ground). Not a very stable connection. I taped pins 3 & 4 so they wouldn't short out. I did get the back up camera working. If you want to enter address in the nav screen, you have to press the middle button on the back left side of the steering wheel each time you want to disable the lockout of enter address feature. When you turn off the ignition the lockout comes back.

Next I'm trying to figure out how to install a second camera for front end rock spotting under the Jeep. Navtool tech support says you have to download f/w into the blue box device to enable the switching for 2nd camera. When I went to download it said "fatal error selected f/w can't be located...more phone calls tomorrow. It does seems to work so far but is very frustrating...
dgerb is offline   Quote Quick Reply
Old 04-23-2014, 11:08 PM   #28
Jeeper
 
Join Date: Apr 2014
Posts: 41
Navtool

Quote:
Originally Posted by dgerb View Post
I have a 2013 JKU and I'm having a simular problem with Navtool. I got the little blue box called Mygig cam kit which included a harness and camera cable with absolutely no instructions or schematics. My phone calls were futile. I finally found some information on various other forums. The back up camera cable is plugged in on the back of the radio/nav unit pins 3 & 4(ground). Not a very stable connection. I taped pins 3 & 4 so they wouldn't short out. I did get the back up camera working. If you want to enter address in the nav screen, you have to press the middle button on the back left side of the steering wheel each time you want to disable the lockout of enter address feature. When you turn off the ignition the lockout comes back.

Next I'm trying to figure out how to install a second camera for front end rock spotting under the Jeep. Navtool tech support says you have to download f/w into the blue box device to enable the switching for 2nd camera. When I went to download it said "fatal error selected f/w can't be located...more phone calls tomorrow. It does seems to work so far but is very frustrating...
I feel your pain. I spent two weeks fooling with Navtool & had my Lockpick up & running in two days including shipping time!
Jeepsforkeeps is offline   Quote Quick Reply
Old 04-24-2014, 11:22 PM   #29
Jeeper
 
Join Date: Oct 2012
Posts: 53
Quote:
Originally Posted by dgerb View Post
I have a 2013 JKU and I'm having a simular problem with Navtool. I got the little blue box called Mygig cam kit which included a harness and camera cable with absolutely no instructions or schematics. My phone calls were futile. I finally found some information on various other forums. The back up camera cable is plugged in on the back of the radio/nav unit pins 3 & 4(ground). Not a very stable connection. I taped pins 3 & 4 so they wouldn't short out. I did get the back up camera working. If you want to enter address in the nav screen, you have to press the middle button on the back left side of the steering wheel each time you want to disable the lockout of enter address feature. When you turn off the ignition the lockout comes back.

Next I'm trying to figure out how to install a second camera for front end rock spotting under the Jeep. Navtool tech support says you have to download f/w into the blue box device to enable the switching for 2nd camera. When I went to download it said "fatal error selected f/w can't be located...more phone calls tomorrow. It does seems to work so far but is very frustrating...
I just helped my friend install NavTool and we had to update it for second input to be on, I had to disable Norton antivirus and Microsoft antivirus I think its called Microsoft essentials

He had different brand installed previously that had lockout always enabled and his nav wasn't tracking properly, with NavTool his nav works like it's supposed to
wrangler4eva is offline   Quote Quick Reply
Old 04-25-2014, 11:37 AM   #30
Jeeper
 
KPM171's Avatar
 
Join Date: Jun 2012
Location: Washington, DC
Posts: 89
Quote:
Originally Posted by tomba View Post
Im in the same boat. I want to use Lockpick but have a manual. I called lockpick and they told me they do not have the programming right for the manual...something about the way it picks up putting the Jeep in reverse to activate the camera. They seemed really interested in my idea of turning the camera on manually....I was planning to use an unused A-pillar switch to turn it on and off. They told me "we don't recommend it" but would love to know how it works for me.
If their only concern is turning on the camera, why not just jump the camera's power wire onto the power line for the back up lights?

__________________
2013 Billet Silver Unlimited Rubicon (My Build)
6-Spd, 4.10's, ARB Bull Bar, XRC X20 Winch, sPOD, Rigid Industry Floods, onboard-air, & way more comfortable than a Wrangler has any business being!

Retired but never forgotten

2005 Wrangler TJ
KPM171 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 06:00 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC