P0456 has gone on for years. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-20-2013, 07:33 PM   #1
Newb
 
Join Date: Nov 2013
Posts: 2
P0456 has gone on for years.

P0456 and only that code.

I've had this small leak on the emission system on my wife's 2008 3.8L Wrangler for about 2-3 years now. I've taken it to the dealership and they haven't been able to find the problem either, and I am also a mechanic. The last fews years I was able to use my scanner and reset it so I could get it through PA emissions. Then the light would come back on a week or two after it passed, so I would put it off for the following year. She only drives it mainly in the winter when her Porsche is in storage and she does not do any off roading or anything.

History: The gas tank has been replaced because it was a recall. Ever since they've put the new gas tank in, we've had problems with it and the dealership doesn't want to admit there's a problem with it. It's been to the dealership a few times and they would say it needs this or that, so I would replace it and the light would come back on. Anyone w/ gas tank recall experience this same problem?

What I have done: It has a new gas cap, new purge valve, new evap container, checked all the hoses underneath/engine bay/behind gas fill tube and they all look great I wiped them off and made sure there were no cracks and made sure all the fittings/clamps were all tight.

We've driven it about 160 miles since I put the new parts on and I can't get a green light to go on on my scanner, it stays yellow so it can't get through emissions because it's not ready yet. I did check my scanner with all our other cars and it is working properly.

The only thing I haven't done is take off the new gas tank or check the connections on top because it has to be removed to do so. Judging from the shape of all the other hoses, I assume they are ok. Only other thing I am thinking is to replace the o-rings that are inside the plastic connectors that attach the hoses together.

Is there some sort of emission control module on the car that I can look at?

How far does your gas fill tube stick out on rear 1/4 panel? My gas fill tube barely sticks out, like the base of gas cap it almost touching black plastic molding that goes around fill tube. I was thinking of adjusting the fill tube so it sticks out further, but not sure if that would do anything because the gas cap clicks and feels like it seals tight.

Thanks for any feedback.

jwups0887 is offline   Quote Quick Reply
Old 11-20-2013, 07:50 PM   #2
Jeeper
 
Join Date: Mar 2013
Location: Southern California
Posts: 94
I am having a similar problem but of my own doing. I am going to pressurize the system next week. I know the techs run the vehicle and use the vacuum from the emissions system to suck smoke but I have an extra gas cap and will drill a hole through it and use soap solution to find the leak. If no joy then it's going back to the dealer under warranty.

Happy515Camper is offline   Quote Quick Reply
Old 11-20-2013, 09:41 PM   #3
The Bad Guy

WF Supporting Member
 
daggo66's Avatar
 
Join Date: May 2009
Location: NJ exile living in Baltimore
Posts: 22,288
Have you checked the evap canister?
__________________
Tom

"I've got two things in this world, my balls and my word and I don't break them for no one."
daggo66 is online now   Quote Quick Reply
Old 11-20-2013, 10:35 PM   #4
Jeeper
 
Join Date: Mar 2013
Location: Southern California
Posts: 94
Quote:
Originally Posted by daggo66 View Post
Have you checked the evap canister?
If you are talking to me then yes I have checked all the connections but not the integrity of the canister itself. That is on my list right after the pressure test.
Happy515Camper is offline   Quote Quick Reply
Old 11-21-2013, 06:21 AM   #5
Newb
 
Join Date: Nov 2013
Posts: 2
Yes, the EVAP canister is brand new along w/ new gasket for purge valve.
jwups0887 is offline   Quote Quick Reply
Old 11-21-2013, 07:05 AM   #6
Jeeper
 
Join Date: May 2011
Posts: 2,469
EVAP emissions system small leak, can be a PITA to find. Did they smoke test it yet? That's "usually" fool proof.

Find out if your Jeep has a Fuel Tank Pressure Sensor which is located on the gas tank itself. If that goes you will throw a P0456 code. It isn't something they usually check either.
demarpaint is offline   Quote Quick Reply
Old 11-21-2013, 09:43 AM   #7
Jeeper
 
Join Date: Mar 2013
Location: Southern California
Posts: 94
OP, sorry if I got in the way.
Happy515Camper is offline   Quote Quick Reply
Old 11-22-2013, 12:04 PM   #8
Jeeper
 
GreenRubi's Avatar
 
Join Date: Jul 2011
Location: Raleigh, NC
Posts: 480
Quote:
Originally Posted by jwups0887 View Post
P0456 and only that code.

History: The gas tank has been replaced because it was a recall. Ever since they've put the new gas tank in, we've had problems with it and the dealership doesn't want to admit there's a problem with it. It's been to the dealership a few times and they would say it needs this or that, so I would replace it and the light would come back on. Anyone w/ gas tank recall experience this same problem?
I had a similar emissions code go off after my gas tank was replaced on my 2008 JK. When I first took my JK back to the dealer they said it was normal, to make sure my gas cap was tight and to call them in a week if it did not go away. A week later the engine light was still on.

Took my JK back to the dealer for take a closer look and this time they said they found a bad oxygen sensor. They replaced this sensor, the engine light went off and never returned.

Might not be related in your case, but do you know if your dealer checked all your oxygen sensors?
__________________
2008 Natural Green JK Rubicon
GreenRubi is offline   Quote Quick Reply
Old 12-25-2013, 07:21 PM   #9
Jeeper
 
Bobs Jeep's Avatar
 
Join Date: Sep 2011
Location: Goose Creek, SC
Posts: 100
I had the gas tank recall done on my wife's 2007 JK a couple years ago. It started recently doing the same thing. The check engine light did stay off for a week or two before after I cleared it but now it comes on right after I clear it. Haven't tried any troubleshooting yet.

__________________
2004 "X" Wrangler, Shale Green, 5sp, 6cyl, 33" Duratrac tires, Pro Comp rims JKS 1.25'' body lift, JKS 1" MML.
Bobs Jeep is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:57 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC