Rough Idle? Washing? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-21-2009, 10:10 AM   #1
Jeeper
 
AndyLA's Avatar
 
Join Date: Dec 2008
Location: Mandeville, LA
Posts: 355
Rough Idle? Washing?

I was washing my JK Rubi 4dr this weekend (I know, I know...it is a Jeep) ---
Anyhow about an hour later, I moved in into the garage after I got done fooling around with the hardtop and Raingler nets......

It started running rough on the idle, like it wanted to die......I stepped in and applied some throttle to try to clear it, and it seemed OK. Driven it since and don't notice any issues......Mileage was about 800 on the engine at the time of the occurance.....no high pressure washing or engine cleaning, just exterior with good handwash.

Probably a fluke, but wanted to see if idling issues were common or cause for concerns on the 3.8Ls.....

__________________
º|||||||º
AndyLA is offline   Quote
Old 04-21-2009, 10:12 AM   #2
Jeeper
 
The Real SASQUATCH's Avatar
 
Join Date: Apr 2009
Posts: 40
Isolated case, maybe a loose plug wire, etc on yours, check everything real good. Washed my Rubi engine bay several times when it's cooled down, never had any issues.

__________________
2007 Redrock RUBICON


Remember: “America is not at war. The military is at war. You're at the mall.” Share this with all of your liberal friends since I don't have any.
The Real SASQUATCH is offline   Quote
Old 04-21-2009, 02:15 PM   #3
Jeeper
 
AndyLA's Avatar
 
Join Date: Dec 2008
Location: Mandeville, LA
Posts: 355
Ok, will do....

Thanks.
__________________
º|||||||º
AndyLA is offline   Quote
Old 04-21-2009, 10:33 PM   #4
Jeeper
 
Join Date: May 2008
Location: Cottondale, Alabama
Posts: 37
Happens to me every now and then, think its bad gas.

Calvin
CKimbrow is offline   Quote
Old 04-22-2009, 10:13 AM   #5
Jeeper
 
AndyLA's Avatar
 
Join Date: Dec 2008
Location: Mandeville, LA
Posts: 355
Didn't seem like bad gas.....sounded like a vacuum/loose line issue to be honest.
It cleared up OK ---- haven't noticed it since.
__________________
º|||||||º
AndyLA is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blistered Ignition Coil, Rough at Idle sgblakley TJ Tech Forum 0 04-12-2009 08:18 PM
4.2 rough idle and stalling problem truemainer150 YJ Tech Forum 9 04-12-2008 05:10 PM
rough idle spanky TJ Tech Forum 9 04-08-2008 04:25 PM
rough idle for 5 or 10 minutes... Jonny15 TJ Tech Forum 5 04-02-2008 07:34 PM
I noticed rough idle after lift. bpowa TJ Tech Forum 11 07-31-2007 12:13 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:42 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC