touch nav screen not working? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-06-2013, 02:43 PM   #1
Newb
 
Join Date: Nov 2013
Posts: 4
touch nav screen not working?

I started my jeep from my house this morning and when I got into it this morning my touch nav screen was black. I pressed every single button possible and it's still not turning on. mind you, I didn't plug it in last night and this morning it was -35 with the windchill, Could that be the problem?

_jeepgirl is offline   Quote Quick Reply
Old 12-06-2013, 02:46 PM   #2
Jeeper
 
Join Date: Jul 2013
Location: 29 Palms, CA
Posts: 288
I've seen excessive heat kill electronics, but never excessive cold..

What unit is it? It should have a code (RBZ, etc) under the aux jack.

__________________
2010 Wrangler Sport - Dark Charcoal Peal - 6-speed - 3.21 - Katzkin
ramp4ge is offline   Quote Quick Reply
Old 12-06-2013, 02:51 PM   #3
Jeeper
 
Join Date: Oct 2011
Location: Olympia, WA
Posts: 2,826
If getting up to operating temp did not get you fixed, try disconnecting the battery for a few minutes.

Bob K.
nwbronco is online now   Quote Quick Reply
Old 12-06-2013, 03:06 PM   #4
Newb
 
Join Date: Nov 2013
Posts: 4
Quote:
Originally Posted by ramp4ge View Post
I've seen excessive heat kill electronics, but never excessive cold.. What unit is it? It should have a code (RBZ, etc) under the aux jack.
It says RHB.
_jeepgirl is offline   Quote Quick Reply
Old 12-06-2013, 03:47 PM   #5
Jeeper
 
Chrimbler's Avatar
 
Join Date: Jan 2012
Posts: 417
Extreme cold will cause touch screens to not work, after they are warmed up they should come on. If yours hasn't, after being warmed, I'd say its not that.
Chrimbler is offline   Quote Quick Reply
Old 12-06-2013, 08:51 PM   #6
Jeeper
 
Join Date: Jan 2012
Location: Oak Ridge,NC
Posts: 350
Mine is a 730N RHR, every once in a while it will not boot up. Unfortunately, it would never do it when I could drive to the dealer so they could see it.
X50ARM is offline   Quote Quick Reply
Old 12-07-2013, 03:29 PM   #7
Newb
 
Join Date: Mar 2012
Posts: 13
Mine will occasionally freeze up. Usually it happens when I plug in my iphone. It corrects itself once I turn the Jeep off and restart it.
Lbeato is offline   Quote Quick Reply
Old 12-08-2013, 04:29 PM   #8
Jeeper
 
Pushrod's Avatar
 
Join Date: Feb 2011
Location: Hot Springs, Arkansas
Posts: 191
My nav display froze up once recently with the map displayed. I stopped, killed the engine and after restart of engine everything was working good. Go figure [:/

__________________
Pushrod
2010 Rescue Green Rubicon JKU

If you ever get to thinking that you're a person of great influence, try ordering someone else's dog around.
Pushrod is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 08:14 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC