01 2.5L Problems! - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-22-2014, 08:37 PM   #1
Join Date: Feb 2014
Posts: 8
01 2.5L Problems!

I have a 2001 2.5L TJ with manual transmission, and it has a few problems.

1) Recently, my IAC (Idle Air Control) valve went bad, it was revving up to 3k RPMS in neutral and also accelerating when clutch was pushed in going into 2nd and 3rd. I replaced the IAC, which fixed this problem. But now, there will be times when I stop the Jeep at say, a light or stop sign, and the idle will be very low and will bounce around. A few times it's gotten almost to the point of stalling out. I'm thinking the TPS?

2) When I'm accelerating while in 3rd, 4th, and sometimes even 5th gear, I hear a rattle. It usually happens when the engine is warm, or on a hot day. It might be my exhaust manifold, which is cracked. But I'm really not sure.

3) I noticed a small leak (about 4-5 drops) on my driveway today. It's coming from my driver's side. I can't pinpoint exactly what it is, because of the color of my driveway. Also the fact that I just noticed it after who knows how long it's been drying up there, so there wasn't any distinct odor.

I would really like some opinions, input, anything really. I love my TJ, and want it to be completely optimal. Everything else is great except for these few problems. I have ideas of what might be causing these problems, but I'm not so sure.


googols is offline   Quote
Old 04-22-2014, 08:51 PM   #2
Majnoon's Avatar
Join Date: Apr 2013
Location: Springfield Missouri
Posts: 3,163
For 1 I would still be looking at iac. A bad TPS usually idles high and such. It's sending as low as possible sitting there and you don't die which Is why I would suspect your new iac. Maybe get a Mopar if you didn't. Other possibility is the crankshaft position sensor. Also called the speed sensor in the fsm. Like rpm. It's on the driver side of the bell housing easy as heck to change. 2 bolts. Unfortunately I don't know of any tests to rule one out. Maybe someone else will chime in. Good luck brother. 2 and 3 no clue.
Majnoon is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:34 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC