04 tj loose power and back fire - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-02-2013, 08:54 PM   #1
Jeeper
 
shanes04wrangler's Avatar
 
Join Date: Feb 2012
Location: chicago
Posts: 273
04 tj loose power and back fire

04 tj 5 spd 4.0 139k sometimes when i am a little hard on the skinny peddle the tj will fall on its face a bit and then back fire after i shift into another gear, Like it cant keep up with my driving lol you can feel the power loss and then it pops then it goes fine. only does this once in a while. what you think it is?

shanes04wrangler is offline   Quote
Old 05-02-2013, 08:58 PM   #2
Jeeper
 
Reznor's Avatar
 
Join Date: Mar 2013
Location: Calgary, Alberta
Posts: 193
First things first... when did you last have a tune? If a plug isn't firing properly, the unburned fuel will get into the exhaust instead of being burned in the cylinder, and then ignite there. Your issue could be one of a few, but that's where I'd start.

Reznor is offline   Quote
Old 05-02-2013, 11:17 PM   #3
Jeeper
 
shanes04wrangler's Avatar
 
Join Date: Feb 2012
Location: chicago
Posts: 273
plugs were done last summer, it only does it when i drive like iam in a rush. like i said it falls on its face pops once then its fine. I have all new o2 sensors that i have not put in yet. If the tps was starting to go bad would it cause it too do that cause sometimes my idel will drop to 150 rpm then go back up randomly at lights.
shanes04wrangler is offline   Quote
Old 05-04-2013, 03:17 AM   #4
Jeeper
 
shanes04wrangler's Avatar
 
Join Date: Feb 2012
Location: chicago
Posts: 273
bump
shanes04wrangler is offline   Quote
Old 05-04-2013, 07:23 AM   #5
Jeeper
 
kshaws21's Avatar
 
Join Date: Jun 2011
Location: Northeast Ga. Mountains
Posts: 1,106
Sounds like a failing cat converter may have something to do with it. Do you ever hear any rattling below the passenger seat area?
kshaws21 is offline   Quote
Old 05-04-2013, 08:26 AM   #6
Jeeper
 
TA462's Avatar
 
Join Date: Jul 2012
Location: Port Hope, Ont
Posts: 80
I would check your plugs and wires even though you've replaced the plugs already. They can go bad.
TA462 is offline   Quote
Old 05-04-2013, 04:48 PM   #7
Jeeper
 
shanes04wrangler's Avatar
 
Join Date: Feb 2012
Location: chicago
Posts: 273
nope no rattling, i just put my banks exhaust on last year and the cat was clear, as for plugs i will check them one day also its 04 no wires . We will see if it still happens i just did my anual spring cleaning this morning aka changed oil , removed throttle body and iac and cleaned and sea foamed the intake track(by the i never get a smoke show) this to me tells me there must not be a lot of carbon to be burned off. o2 sensors i still have to change but i left them is Michigan at my dads so i have to wait.
shanes04wrangler is offline   Quote
Old 05-04-2013, 07:38 PM   #8
Jeeper
 
tkfx's Avatar
 
Join Date: Aug 2012
Location: La Crescenta, CA
Posts: 1,526
You said you chrcked the cats. Now did you check the mini cats? Or just the large cat beside the exhaust. Sounds like a clogged cat to me. If you haven't touched your cats for 130k then I'd take a look at em. Ecpessialy the mini cats located right under the Exhaust manifold.
__________________
Yellow 04 LJ 4spd Auto: Building In Progress
-JKD44 Front w/ 5.13, 1" Stretch, OX Locker, OX Diff Cover, RuffStuff 1 Ton GM Steering, RuffStuff Panhard Kit, Retubed 3"x0.25 DOM, Gusseted
-JKD44 Rear w/ 5.13, 4" Stretch
-King 14" Remote Resi Coilovers Front/Rear, 37" MTR/K, Clayton 3-Link Front, 4-Link Rear

My Build Thread
tkfx is offline   Quote
Old 05-04-2013, 08:43 PM   #9
Jeeper
 
shanes04wrangler's Avatar
 
Join Date: Feb 2012
Location: chicago
Posts: 273
naw just the last one, the pre cats i have not looked at.

shanes04wrangler is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:15 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC