05 Rubicon drive shaft splines worn? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-20-2013, 04:51 PM   #1
Jeeper
 
HobieSailor's Avatar
 
Join Date: May 2012
Posts: 67
05 Rubicon drive shaft splines worn?

I hear a very loud single click noise when I first take off or when I let of and get back on gas again. I thought it may the U-joints so I replaced both of them and the noise did not change.

I did notice while I had the drive shaft out that the splines had noticeable rotational play, is this common? Is there any play in splines from factory? I have no driveline vibration issues.

My plan right now is to pull the boot off and grease them to see if noise changes.

HobieSailor is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 11:14 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC