05 Ruby - Auto Transmission Randomly Slips into Neutral - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-30-2012, 06:42 AM   #1
Newb
 
Join Date: Nov 2012
Posts: 1
05 Ruby - Auto Transmission Randomly Slips into Neutral

Have an 05 Rubicon thats developed a tranny problem over the last week.

At least once every time I'm driving, the transmission will randomly slip into neutral, the rpm's will jump and then it catches again and seems fine. No consistency as to the conditions when it happens either (both highway and city driving, at all speeds).

Fluid levels are fine & my mechanic didn't have any ideas as to what it could be, short of tearing into it. It's more of a pain in the arse than anything but I sure as hell don't want to keep having to put up with it. Any ideas are appreciated.

tchwojdak is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:56 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC