06 electrical issues - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-15-2012, 11:45 AM   #1
Jeeper
 
Join Date: Sep 2012
Location: marshall tx
Posts: 21
06 electrical issues

I just bought an 06 Unlimited and everything worked fine when I test drove it.I went out to drive it last night and the air bag light was on. After a little bit of driving I noticed that the blinkers, wipers, and blower motor didn't work either. Also, the radio didn't work from the get go, but would display the time. When all of this was happening, The radio showed no time. I cranked it up this morning and drove it to town, and everything worked like it should. The clock on the factory radio even displayed the time like previously. Does anyone have any idea what could b causing this? The jeep has a 6" long arm lift kit with 33's. Its also a 4.0 with an auto.

Thanks
Trey

laynrocker84 is offline   Quote Quick Reply
Old 09-15-2012, 11:58 AM   #2
Jeeper
 
ciamex's Avatar
 
Join Date: Nov 2011
Location: Glendale AZ
Posts: 32
The list is so long, who knows.. it could be anything...

loose ground, loose relay, loose power wire..

Best way to do it ... is grab a wiring schematic and check everything starting from the battery... check for loose battery cables... then just keep following wires back...

its going to be a while... hell could even be on the back of the fuse panel.

ciamex is offline   Quote Quick Reply
Old 09-15-2012, 02:58 PM   #3
Jeeper
 
Evpjr's Avatar
 
Join Date: May 2012
Location: Bakersfield
Posts: 296
Images: 1
Cause #1: It's made by Chrysler Motors. Chrysler products are notorious for electical problems.
Cause #2: It's anybody's guess.
Evpjr is offline   Quote Quick Reply
Old 09-15-2012, 03:34 PM   #4
Jeeper
 
JRoweMDN's Avatar
 
Join Date: Apr 2012
Location: Keystone Heights
Posts: 322
Wiggle the key back and forth if it does it again. I have to turn my key forward towards crank just a little bit to get the blower to come on and the airbag light to turn off. Mine needs a new ignition switch just have not made time yet.
JRoweMDN is offline   Quote Quick Reply
Old 09-15-2012, 07:14 PM   #5
Jeeper
 
Join Date: Sep 2012
Location: marshall tx
Posts: 21
Thanks for the replys, I'll try the key first as it seems to be the easiest! lol

Thanks
Trey
laynrocker84 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:05 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC