2000 2.5 wrangler problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-10-2013, 07:20 PM   #1
Newb
 
Join Date: Jan 2013
Posts: 6
2000 2.5 wrangler problems

I have a 2000 wrangler with 2.5 auto ,Im going down the highway @ 65 mph and the jeep just died.I tried to start it but wouldn't start,it would crank but not start.so I let it set for about 30 minutes and it started .i got a mile down the road and it died again.same thing,let it sit and it started again.got home and started it again and let it idle .It idled for 5 minutes and died.can anyone help please. thanks

bzack2013 is offline   Quote Quick Reply
Old 01-10-2013, 10:34 PM   #2
Jeeper
 
screwystewy's Avatar
 
Join Date: Jan 2012
Location: Ohio
Posts: 210
Fuel pump maybe?

screwystewy is offline   Quote Quick Reply
Old 01-10-2013, 11:39 PM   #3
Jeeper
 
Dextreme's Avatar
 
Join Date: Oct 2011
Location: Oregon City, OR
Posts: 3,613
Images: 1
I too would guess fuel pump or fuel filter (if it has one)....but remember that the thing requires: Fuel, Spark, and Air to run. Start with simple things to narrow it down.
__________________
'99 Chilli Pepper TJ Wrangler "Mistress"
33x12.5 DuraTracs
Zone 4.25"
Dextreme is offline   Quote Quick Reply
Old 01-10-2013, 11:41 PM   #4
Jeeper
 
mikeym's Avatar
 
Join Date: Apr 2012
Location: Peoria Heights,IL
Posts: 177
I'd also look at the crank positioning sensor
mikeym is offline   Quote Quick Reply
Old 01-11-2013, 07:14 AM   #5
Jeeper
 
G-LOVE's Avatar
 
Join Date: Apr 2012
Location: Amesbury, MA
Posts: 218
Any recent work done to it? Is the engine throwing any codes? Engine lights? How many miles?
__________________
2002 Sport, for waves & woods,...and winter.
G-LOVE is offline   Quote Quick Reply
Old 01-11-2013, 08:44 AM   #6
Newb
 
Join Date: Jan 2013
Posts: 6
sending a p0340code
bzack2013 is offline   Quote Quick Reply
Old 01-11-2013, 08:56 AM   #7
Jeeper
 
mikeym's Avatar
 
Join Date: Apr 2012
Location: Peoria Heights,IL
Posts: 177
According to the search on this sight, that code is a camshaft positioning sensor.
mikeym is offline   Quote Quick Reply
Old 01-11-2013, 10:12 AM   #8
Jeeper
 
Throwmorepartsatit's Avatar
 
Join Date: Mar 2012
Location: Carlsbad ca
Posts: 90
Yep exact same thing happened to me, but my cps actually worked itself loose.
Throwmorepartsatit is offline   Quote Quick Reply
Old 01-11-2013, 12:16 PM   #9
Newb
 
Join Date: Jan 2013
Posts: 6
was yours a 2.5 engine
bzack2013 is offline   Quote Quick Reply
Old 01-11-2013, 12:48 PM   #10
Jeeper
 
Steve305's Avatar
 
Join Date: Nov 2012
Location: Soddy Daisy, TN
Posts: 389
Sounds like a CPS problem. I had a Mopar that did the same thing. Change the CPS.
__________________
Just plain 'ole Steve.
Steve305 is offline   Quote Quick Reply
Old 01-15-2013, 07:01 PM   #11
Newb
 
Join Date: Jan 2013
Posts: 6
changed position sensor and the ignition coil and still same thing.and i do have fuel pressure.any solutions

bzack2013 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:32 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC