2000 2.5L Intermittent High revving. Help! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-03-2013, 08:31 PM   #1
Jeeper
 
Join Date: Aug 2011
Location: Mpls MN
Posts: 29
2000 2.5L Intermittent High revving. Help!

Hey folks,
So...after the truck gets warm. If I am in 5th gear, and I down shift to slow down, or say come off the freeway to a stop, the idle drops slightly and then revs up to 3000, down a bit and then back up until I either shut it off, or shift into first/pull away from a stop. Almost like it hunts at idle a bit after being on the freeway. It does not throw the check engine light. Aside from the throttle linkage sticking, I am lost. Also, it does not do it all the time. Help.
-Erin

lexluthier72 is offline   Quote
Old 06-06-2013, 08:14 PM   #2
Jeeper
 
Join Date: Aug 2011
Location: Mpls MN
Posts: 29
bump...anyone?

lexluthier72 is offline   Quote
Old 06-06-2013, 08:28 PM   #3
Jeeper
 
Mulvihill64's Avatar
 
Join Date: Jun 2011
Location: Central Jersey
Posts: 359
Maybe the IAC try cleaning the throttle body and the IAC http://www.jeepforum.com/forum/f9/cl...mmies-1114849/
__________________
My Build
Mulvihill64 is offline   Quote
Old 06-06-2013, 10:02 PM   #4
Newb
 
Join Date: Apr 2013
Posts: 6
That does sound like the iac alot to me as well...it wont send a code either..good luck
carterj78 is offline   Quote
Old 06-06-2013, 10:27 PM   #5
Jeeper
 
03 sahara jeeper's Avatar
 
Join Date: Apr 2011
Posts: 550
IAC or vacuum leak.
03 sahara jeeper is offline   Quote
Old 06-07-2013, 04:56 PM   #6
Jeeper
 
Join Date: May 2013
Location: Southern Vermont
Posts: 17
had same issue in my durango, it was tps
__________________
Im ready,... lets go get stuck!
Rottie Crawler VT is offline   Quote
Old 04-27-2014, 12:46 PM   #7
Jeeper
 
Join Date: Aug 2011
Location: Mpls MN
Posts: 29
Hey All...I have been away from the forums for a LONG time. I cleaned the IAC and got no change, it also now will stick at low idle (below 500) and stumble intermittently. Thoughts?
-Erin

P.s.- No engine code/CEL
lexluthier72 is offline   Quote
Old 04-27-2014, 02:47 PM   #8
Jeeper
 
Join Date: Aug 2011
Location: Mpls MN
Posts: 29
Ok....I just replaced the IAC. Will report back...

lexluthier72 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:21 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC