2004 TJ O2 Sensor Codes - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-18-2012, 02:30 PM   #1
Jeeper
 
Frshmt's Avatar
 
Join Date: Jun 2012
Posts: 346
My wife's 2004 TJ (4.0/Auto) threw a MIL a couple months back. Showed P0138 and P0158, which is high voltage on downstream O2 for both banks. Replaced both sensors hoping it was an easy fix, but after about 30 miles of driving the light came back on, throwing the same codes again.

I've traced all the wiring I can find from the O2 sensors but the entire harness, the grounds, etc all look brand new (part of why I bought the Jeep).

I'm at a loss and could use the advice of those in the know. Anyone have this problem before and come up with a proper resolution to this problem?

__________________
Mine: 2012 JKU Sport, Deep Cherry, Auto, 3.73s, Rock Krawler 3.5" Flex, chitty Procomp shocks, JKS Discos, Rubi rails, A.C.E. sliders, EVO ProTek Skids, EVO Rockstars, JCR Dagger with lights and tire carrier, PSC Brawler Lite with custom stinger and grill hoop, ENGO 10k with synthetic, 35x12.50-15 BFG KM2s, MOPAR flat flares.
Wife's: 2004 TJ Sport, 4.0/Auto, 2" BB, stock JKU shocks, JKS front LCAs, 31x10.50-15 BFG ATs.
Frshmt is offline   Quote
Old 06-18-2012, 02:32 PM   #2
Jeeper
 
Frshmt's Avatar
 
Join Date: Jun 2012
Posts: 346
It runs great. crappy mileage (13mpg- standard for a 4.0/Auto I believe), but does have to downshift from OD to accelerate from 75mph, even on 31s with 3.73s, which I found odd.

__________________
Mine: 2012 JKU Sport, Deep Cherry, Auto, 3.73s, Rock Krawler 3.5" Flex, chitty Procomp shocks, JKS Discos, Rubi rails, A.C.E. sliders, EVO ProTek Skids, EVO Rockstars, JCR Dagger with lights and tire carrier, PSC Brawler Lite with custom stinger and grill hoop, ENGO 10k with synthetic, 35x12.50-15 BFG KM2s, MOPAR flat flares.
Wife's: 2004 TJ Sport, 4.0/Auto, 2" BB, stock JKU shocks, JKS front LCAs, 31x10.50-15 BFG ATs.
Frshmt is offline   Quote
Old 06-18-2012, 02:55 PM   #3
Jeeper
 
InvertChaos's Avatar
 
Join Date: Sep 2010
Location: NoVa
Posts: 8,099
Moved to TJ section
__________________
|2004 Jeep TJ "Green Machine"|4.0L 5 speed Dana44|33x12.50x15 Goodyear Duratracs|2.5" OME HD coils + 1.25" body lift|OME NitroSport shocks|4.56 gears|Skid Row Engine Skid|BCC Sliders|Currie AntiRock|
InvertChaos is offline   Quote
Old 06-18-2012, 03:58 PM   #4
I am JD & It's my Dream

WF Supporting Member
::WF Administrator::
 
JDsDream's Avatar
 
Join Date: Jan 2009
Location: The Peach State
Posts: 27,792
Images: 4
Check for leaks/cracks in the manifold.
__________________
The kind of woman that when my feet hit the floor each morning the devil says "Oh Crap, She's up!"

To All Of Our Forum Veterans and Active Service Members.
Our Debt To You Is Greater Than We Could Ever Repay.
Thank You

Become a Supporting Member!
JDsDream is online now   Quote
Old 06-18-2012, 04:12 PM   #5
Jeeper
 
Join Date: Apr 2012
Location: Cedarcreek, Mo.
Posts: 113
Have your catalytic converters checked out, particularly the 3rd cat downstream. Too much back-pressure could cause O2 sensor errors and can certainly affect mileage and power.
Molaker is offline   Quote
Old 07-18-2012, 09:00 PM   #6
Jeeper
 
Frshmt's Avatar
 
Join Date: Jun 2012
Posts: 346
Quote:
Originally Posted by JDsDream View Post
Check for leaks/cracks in the manifold.
No leaks or cracks that I can find in the exhaust manifold.

Quote:
Originally Posted by Molaker View Post
Have your catalytic converters checked out, particularly the 3rd cat downstream. Too much back-pressure could cause O2 sensor errors and can certainly affect mileage and power.
There is not a third cat downstream. There is an upstream and a downstream. Front bank and rear bank.

I've been reading like crazy and I have no clue what is wrong. I checked the fuse, the relay, the wiring, the exhaust manifold... I'm at a loss.

Anyone else have any suggestions?
__________________
Mine: 2012 JKU Sport, Deep Cherry, Auto, 3.73s, Rock Krawler 3.5" Flex, chitty Procomp shocks, JKS Discos, Rubi rails, A.C.E. sliders, EVO ProTek Skids, EVO Rockstars, JCR Dagger with lights and tire carrier, PSC Brawler Lite with custom stinger and grill hoop, ENGO 10k with synthetic, 35x12.50-15 BFG KM2s, MOPAR flat flares.
Wife's: 2004 TJ Sport, 4.0/Auto, 2" BB, stock JKU shocks, JKS front LCAs, 31x10.50-15 BFG ATs.
Frshmt is offline   Quote
Old 07-19-2012, 09:32 PM   #7
Jeeper
 
Frshmt's Avatar
 
Join Date: Jun 2012
Posts: 346
__________________
Mine: 2012 JKU Sport, Deep Cherry, Auto, 3.73s, Rock Krawler 3.5" Flex, chitty Procomp shocks, JKS Discos, Rubi rails, A.C.E. sliders, EVO ProTek Skids, EVO Rockstars, JCR Dagger with lights and tire carrier, PSC Brawler Lite with custom stinger and grill hoop, ENGO 10k with synthetic, 35x12.50-15 BFG KM2s, MOPAR flat flares.
Wife's: 2004 TJ Sport, 4.0/Auto, 2" BB, stock JKU shocks, JKS front LCAs, 31x10.50-15 BFG ATs.
Frshmt is offline   Quote
Old 07-23-2013, 03:32 PM   #8
Newb
 
amazing189's Avatar
 
Join Date: May 2013
Posts: 7
Did you ever figure this out? I have the same exact codes being thrown on my 2004 4.0. I had P0432 about a month ago and installed dummy o2 sensors I bought online. The P0432 code went away and now I'm getting p0138 and p0158.

Thanks,
Danny
amazing189 is offline   Quote
Old 07-23-2013, 03:44 PM   #9
Commercial Member

5-Year WF Supporting Member
 
Big Sarge's Avatar
 
Join Date: Dec 2012
Location: Chester Virginia
Posts: 4,458
Not sure if he got his problem fixed but a common problem with o2 sensors in the TJ is that they were replaced with sensors other than NTK brand. Rock auto has them for the cheapest that I have found. Only the NTK brand will perform properly for an extended period of time for us.

Here is a discount code as well

1574541712895315

Using Your Discount Code

Enter the code above in the "How did you hear about us" line of the shopping cart. If you are using our traditional HTML catalog, please click the "Apply" button to the right of the field. Your discount will automatically appear, subtracted from your parts order total. Orders using discount codes must be placed online. Phone orders are not eligible for discounts.

Please note: We sometimes get calls from people who put the word "discount" in front of their code and do not get the discount. Please enter ONLY the discount code, no other words or numbers. Code must be entered before order is submitted to receive discount.
__________________
click the link below to view my Custom pool ball shift Knobs
http://www.wranglerforum.com/f37/custom-camo-pool-ball-shifters-224388.html

NEW AUTOMATIC TJ SHIFT KNOB AVAILABLE at this link

http://www.wranglerforum.com/f37/aut...-new-post.html

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)
Big Sarge is online now   Quote
Old 07-23-2013, 05:04 PM   #10
Newb
 
amazing189's Avatar
 
Join Date: May 2013
Posts: 7
Thanks! I'll check them out when I get home.
amazing189 is offline   Quote
Old 09-06-2013, 06:36 AM   #11
Newb
 
amazing189's Avatar
 
Join Date: May 2013
Posts: 7
Bought and installed the NTK sensors from Rock Auto., reset CEL. However, after 100 miles or so if driving the CEL is back on throwing the p0138 and p0158 codes.

I checked the manifold...no cracks. The cats look good, but maybe the insides are trashed? Any help, suggestions or feedback would be much appreciated.

Getting crappy gas mileage and performance stinks.

amazing189 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:20 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC