2005 TJ Transmission - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-14-2013, 02:11 PM   #1
Join Date: May 2010
Posts: 1
2005 TJ Transmission

I have a 2005 Jeep Wrangler TJ Sport with a 4.0 and automatic 4 speed transmission. About 2 weeks ago the service engine light came on then the transmission would not shift past 2nd gear. I pulled to the side of the road, shut the engine off, looked under the hood, and checked fluids. I could not see anything wrong so I decided to drive the Jeep home slowly. When I started the Jeep the engine light was still on however the Jeep shifted fine. The next time I started the Jeep the engine light was off and it drove fine.

The Jeep has done this 8 times since then. I scanned the Jeep and it threw P0700 Transmission Malfunction Present, P0760 Shift Solenoid C Malfunction, & P0871 Transmission Fluid Pressure Sensor/Switch C Circuit Range/Performance.

I took the Jeep to a local transmission shop and he scanned the Jeep coming up with the same codes. They have replaced the shift solenoid pack, the fluid, and the filter. The Jeep drove great for 2 days then it did the same thing. I have not had a chance to re-scan the Jeep so I do not know what codes it is displaying now.

I was just wondering if anyone else has had this problem, or has any expertise in this, and if so what fixed it.

3441 is offline   Quote
Old 10-14-2013, 05:02 PM   #2
MTJeepTJ's Avatar
Join Date: Jan 2013
Location: Lolo Montana
Posts: 406
I think 2005 was one of the years that had PCM issues. Im sure somebody will chime in. Only other thing i could think of would be sticking valves in the valvebody. Those transmissions have a solenoid switch valve that sticks. Its part of the valvebody not the solenoid part.

In The Mountains
MTJeepTJ is offline   Quote
Old 07-12-2014, 11:54 AM   #3
PBDream's Avatar
Join Date: Mar 2014
Location: Daphne
Posts: 162
Same exact problem here, 2005 replaced the solenoid and everything worked fine for 2 days and now it's back again. Ever find out the problem?
PBDream is offline   Quote
Old 03-13-2015, 07:42 AM   #4
Join Date: Feb 2012
Posts: 5
same exact scenario here. Im not happy

2 days after havin the silenoid replaced it stuck in 2cnd gear, turn of motor shifts now but codes P0700 P0776 wont clear. I dropped $900 a the dealeship 3 days ago and this shit happens again. Id like to find an alternate but superior transmission replacement.
Im not sure what to do at this time.
rjn500 is offline   Quote
Old 03-13-2015, 08:20 AM   #5
Join Date: May 2013
Location: Westchester, IL
Posts: 3,151
aw4 swap? its a shame that isnt the trans they put in from 97 on
Ironhead Jed is online now   Quote
Old 03-13-2015, 11:18 AM   #6
Join Date: Sep 2014
Posts: 387
The dealership should warranty all their work, go back to them and complain, loudly
mattstj is offline   Quote
Old 03-13-2015, 12:30 PM   #7

WF Supporting Member
fishband's Avatar
Join Date: Jul 2011
Location: ORLANDO FL
Posts: 241
I went through this a couple years back....ended up having to go to dealer and having pcm replaced and flashed......expensive but solved the problem.....hope this helps...wished I hadnt payed a tranny shop before that.....they tried solenoid swap as well....didnt help.
I don't wanna grow up
fishband is offline   Quote
Old 09-18-2015, 07:23 AM   #8
Join Date: Feb 2012
Posts: 5
I have a 2005 Jeep Wrangler Rubicon with an automatic transmission. It got stuck in second gear and could be reset by turning the ignition switch on and off. I took it to the dealership for times. They replace the solenoid the Valve body installed a transmission cooler and it replaced PCM each one of these fixes did not fix the jeep so now I've got $2000 in his Jeep and still have a transmission to get stuck in second gear needless to say I'm pissed off I really don't know where to go from here but I think I might not ever own a jeep again

rjn500 is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:33 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC