97 2.5 spit and sputter after 1 minute of running - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-02-2013, 01:38 PM   #1
Jeeper
 
Plowboy1970's Avatar
 
Join Date: Nov 2010
Location: Burlington WI
Posts: 1,187
97 2.5 spit and sputter after 1 minute of running

Well, I have owned this 97 SE 2.5 stick for 2 weeks and getting it fixed up. Owner neglected it for YEARS. But it was cheap and ran. Owner said it needed a tune up. Well I put in new copper plugs, wires, cap and rotor and cleaned out the IAC. Every time I start it cold, or has been sitting for more than 15 minutes, after 1-1.5 minutes of running it starts to run ruff. If sitting it will spit and sputter, but never die. I can rev it up but its missing will last almost a minute. If I am driving and it does it, it feels like someone shut the Jeep off. Put the gas peddle to the floor and it will run, but backfire thought the intake a few times. Beat on it for 15 seconds and it will run fine. From then on, it will run for hours and not give any problems. There is no stored codes and no check engine light. I am guessing the upstream O2 sensor is bad and not warming up quick enough?? Computer switching from open loop to closed loop and sensor not reading right? Why not setting a code??? Your ideas?

PS. I normally drive a 97 Sport 4.0 auto and I now can say, the 2.5 is a dog compared to the 4.0!!!

Plowboy1970 is offline   Quote Quick Reply
Old 03-02-2013, 08:37 PM   #2
Jeeper
 
Plowboy1970's Avatar
 
Join Date: Nov 2010
Location: Burlington WI
Posts: 1,187
No one has had this problem? I will figure it out.

Plowboy1970 is offline   Quote Quick Reply
Old 03-02-2013, 09:14 PM   #3
Jeeper
 
Fatherof2's Avatar
 
Join Date: Jun 2010
Location: lugoff, sc
Posts: 69
Sounds like what mine was doing....changed upstream o2 sensor and have had no more problems
Fatherof2 is offline   Quote Quick Reply
Old 03-02-2013, 11:04 PM   #4
Jeeper
 
Plowboy1970's Avatar
 
Join Date: Nov 2010
Location: Burlington WI
Posts: 1,187
Fatherof2 , that is what I am thinking it is. But no codes?? I know no Bosch O2 sensors from reading here. Time to search posts to find the good ones. Thanks.
Plowboy1970 is offline   Quote Quick Reply
Old 03-02-2013, 11:17 PM   #5
Jeeper
 
JT02's Avatar
 
Join Date: Jun 2012
Location: South Florida
Posts: 43
Mine did something similar, cleaned the o2 sensor, changed ignition coil, spark plugs and wires and it is gone..
JT02 is offline   Quote Quick Reply
Old 03-02-2013, 11:17 PM   #6
Jeeper
 
Plowboy1970's Avatar
 
Join Date: Nov 2010
Location: Burlington WI
Posts: 1,187
Looks like I will be getting NTK 23506 for it. Will see if that fixes it.
Plowboy1970 is offline   Quote Quick Reply
Old 03-02-2013, 11:21 PM   #7
Jeeper
 
JT02's Avatar
 
Join Date: Jun 2012
Location: South Florida
Posts: 43
Cheap part and easy to get to, cant hurt to replace it regardless.
JT02 is offline   Quote Quick Reply
Old 03-03-2013, 12:13 AM   #8
Jeeper
 
FirehawkTJ's Avatar
 
Join Date: Apr 2012
Posts: 62
I just did the exact same thing for a buddy of mine with the 2.5 spit sputter problem. Change that upstream O2 sensor and ride on happy! Best of luck!
FirehawkTJ is offline   Quote Quick Reply
Old 04-16-2013, 06:09 PM   #9
Jeeper
 
Plowboy1970's Avatar
 
Join Date: Nov 2010
Location: Burlington WI
Posts: 1,187
Well, I tried, and I tried to get it out. No way was it coming. So I drove it to a shop and they charged me $60 to change it. It was getting worse and worse spitting and bucking and backfiring!!!! My first drive with it changed was so smooth and nice. Like everyone has said here....if you have running problems....change the oxygen sensor.

Now to fix some other problems!!!

Plowboy1970 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:34 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC