97 2.5L running hot - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-05-2013, 03:27 AM   #1
Jeeper
 
Join Date: Mar 2013
Posts: 32
97 2.5L running hot

So I have been having problems out of my 4 cylinder TJ. At first I suspected a bad coolant temp sensor. On further inspection I determined my radiator probably needed to be replaced as it looked like it was corroding on the outside and was leaking slightly. I put in an OEM radiator single row... my old radiator was the old two row style... and an OEM thermostat and gasket. Flushed all the brown gunk out of the cooling system and refilled with 50/50 zerex coolant and burped the system. All was well for a day... Jeep ran for a day slightly below 210. Then it started going into the red again. My next step is the water pump but before I change it and get it all back together could my head gasket be blown or maybe even my block be cracked? I have no white smoke from the tail pipe and there isn't any moisture coming out of it either. My jeep also isn't running poorly. I know I should do a compression test but is there any other signs of a blown head gasket that I might have?

iamthewalrus016 is offline   Quote Quick Reply
Old 05-06-2013, 03:27 AM   #2
Jeeper
 
InvisiblePants's Avatar
 
Join Date: Jan 2013
Location: Charleston, SC
Posts: 517
Images: 11
I would check the water pump. It could be the impeller blades have corroded away.


Click image for larger version

Name:	uploadfromtaptalk1367825230079.jpg
Views:	73
Size:	67.5 KB
ID:	245732
Click image for larger version

Name:	uploadfromtaptalk1367825260907.jpg
Views:	66
Size:	48.5 KB
ID:	245733

InvisiblePants is offline   Quote Quick Reply
Old 05-06-2013, 03:50 AM   #3
Jeeper
 
Join Date: Mar 2013
Posts: 32
Dont think the blade sides can really be seen but they looked pretty good... I think its just a after market crap brand that failed... There was coolant every where... It looked like it originated from the pump so since this is a crappy one from where ever I will assume it failed.
Attached Thumbnails
Click image for larger version

Name:	IMG_0433.jpg
Views:	26
Size:	232.3 KB
ID:	245734   Click image for larger version

Name:	IMG_0434.jpg
Views:	36
Size:	232.3 KB
ID:	245735  

iamthewalrus016 is offline   Quote Quick Reply
Old 05-06-2013, 06:32 PM   #4
Jeeper
 
Join Date: Mar 2013
Posts: 32
If it isn't the waterpump and its my head gasket or a cracked block... How is it that I am asymptomatic as far as those two issues go?
iamthewalrus016 is offline   Quote Quick Reply
Old 05-10-2013, 04:09 AM   #5
Jeeper
 
Join Date: Mar 2013
Posts: 32
So I replaced the water pump and flushed the system again then let all the air out of the system.... I took it for a drive and cranked the heat to see if it worked and no hot air came out then my check gauges light came on and my amps were maxed out. I pulled into my drive way and shut it down. Then tried to start her up again... Nothing. I went to check under the hood and decided to release the pressure on the radiator cap.... After I released the pressure it would start again but now my engine is knocking like nobody's business... Sounds like something is up with the valves... I am pretty sure my head gasket is blow or my head is completely jacked. Any thoughts?
iamthewalrus016 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:40 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC