97 tj auto no cold shift - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-05-2008, 10:09 PM   #1
Jeeper
 
autogyver's Avatar
 
Join Date: Dec 2007
Location: MOUNTAINS WESTERN N.C.
Posts: 96
Question 97 tj auto no cold shift

has anyone had the problem with an auto 4.0 tj not wanting to shift into drive while it is cold, it shifts from first to second fine but when it should go to drive it won't shift until you tach the fool out of it. changed fluid and filter,adjusted throttle shift control cable. no idea unless it's a shift solenoid.any help would be great ...........thanks

autogyver is offline   Quote Quick Reply
Old 01-05-2008, 10:20 PM   #2
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
Cold like not warmed up or cold out side?

Try putting it in neutral and revving it to 1300rpm for about 10 seconds. That should get the fluid going.

AzTJ is offline   Quote Quick Reply
Old 01-05-2008, 10:24 PM   #3
Jeeper
 
autogyver's Avatar
 
Join Date: Dec 2007
Location: MOUNTAINS WESTERN N.C.
Posts: 96
cold like under 50 degrees and first 2 miles after that usuall??? does fine. i have tried the high idle 1500rpm did not help.......just my luck.....
autogyver is offline   Quote Quick Reply
Old 01-06-2008, 07:00 PM   #4
Jeeper
 
parrot head's Avatar
 
Join Date: Jul 2007
Location: Connecticut
Posts: 406
Quote:
Originally Posted by autogyver View Post
has anyone had the problem with an auto 4.0 tj not wanting to shift into drive while it is cold, it shifts from first to second fine but when it should go to drive it won't shift until you tach the fool out of it. changed fluid and filter,adjusted throttle shift control cable. no idea unless it's a shift solenoid.any help would be great ...........thanks
I had similar problem last year only mine shifted fine cold, and would not shift into drive when warmed up. I changed the trans filter and fluid and included about a pint of Marvel Mystery Oil when refilling trans. After about 10-15 miles it was shifting like new!
__________________
“He who knows not and knows not that he knows not, he is a fool, shun him.
He who knows not and knows he knows not, he is simple, teach him.
He who knows and knows not he knows, he is asleep, wake him.
But he who knows, and knows he knows, he is wise, follow him.”


89 yj 4 banger 5sp. 2" BL 31x10.50 fixed up and sold
97 tj 4.0 Auto 4"RC lift 33x12.50 mud rovers on outlaw IIs . Smitty bumpers
parrot head is offline   Quote Quick Reply
Old 01-06-2008, 07:47 PM   #5
Jeeper
 
4.0l sahara's Avatar
 
Join Date: Apr 2007
Location: shelton,ct
Posts: 2,228
Bring it and get it flusshed and new fluid and filter.
__________________
99 sahara
4.0/np231/ax15/d30/d35
flowmaster40,hpd30 with aussie locker,currie upper joints,4.88's, lca skids,chromo shafts,vanco brakes,d35 with super 35 and arb locker,re 4.5" springs,currie arms,re front uppers,Re shocks in back,walkerevens shocks up front, Re track bars with currie jj joints,anti rock,ss brake lines,re rear sway bar links,jks 1.25" bl and mml,bfg 35x12.5 km2's,craiger soft 8's,ome steering stabilizer,currie hd steering,rockmen front bumper,emp tank skid,lots more too.
4.0l sahara is offline   Quote Quick Reply
Old 01-06-2008, 08:18 PM   #6
Jeeper
 
autogyver's Avatar
 
Join Date: Dec 2007
Location: MOUNTAINS WESTERN N.C.
Posts: 96
i have already flushed and filter change with seafoam ,,,,iwill try marvel mystery...maybe it will solve my mystery or misery...thanks guys
autogyver is offline   Quote Quick Reply
Old 01-06-2008, 11:53 PM   #7
Jeeper
 
Rawkon's Avatar
 
Join Date: Apr 2005
Location: fullerton/big bear
Posts: 2,061
Send a message via AIM to Rawkon Send a message via MSN to Rawkon
make sure your running atf 4 or synthetic too. lucas makes a good trnas tune also that you just add in with your current fluid.

clogged filters are the number 1 cause of tranny issues.

Rawkon is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
4WD Shift Motor Replacement gtchief YJ Tech Forum 28 02-26-2012 11:34 AM
TRANSFER CASE very hard to shift, why? noodle999 JK Tech Forum 6 07-06-2008 05:11 AM
Severe cold weather driving scotiez General Jeep Discussion 4 02-03-2008 06:36 AM
tow bar for 2007 Wrangler X douglassoilco JK General Discussion Forum 5 09-07-2007 11:35 PM
Old guy's first Jeep exmxr73 WF New Member Check In 12 08-16-2007 08:46 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:10 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC