97 tj heater help!! no heat and its cold. burr - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-24-2010, 05:15 PM   #1
Jeeper
 
AvJeep's Avatar
 
Join Date: Jul 2010
Location: El Paso, TX
Posts: 38
Exclamation 97 tj heater help!! no heat and its cold. burr

well i live in el paso and now its starting to get cold in the morning before pt
but im having a issue with the heater, i believe the control on the inside is working it lights up and when i move the switch i hear some sort of noises but weither cool or hot air it does not blow what so ever. even in highway speeds nothing works and im not sure what fuse it is to check i hear the blower could be bad or the resistor? so if anyone has any advice. or even a simpler way to check the blower since im not to electrical inclined. thanks

AvJeep is offline   Quote
Old 10-24-2010, 05:54 PM   #2
Jeeper
 
Join Date: Jan 2010
Posts: 191
You are saying that the fan motor can be heard blowing and the speed goes up and down with the fan control, but no air (hot or cold) comes out of the defrost or the heat vents?

KCrisp is offline   Quote
Old 10-24-2010, 08:30 PM   #3
Jeeper
 
AvJeep's Avatar
 
Join Date: Jul 2010
Location: El Paso, TX
Posts: 38
Quote:
Originally Posted by KCrisp View Post
You are saying that the fan motor can be heard blowing and the speed goes up and down with the fan control, but no air (hot or cold) comes out of the defrost or the heat vents?
well nothing blows out the vents when im at a idle but when im driving fast it blows but i cant turn it low or any thing so i have no idea
AvJeep is offline   Quote
Old 10-27-2010, 08:33 PM   #4
Jeeper

WF Supporting Member
 
shipjim's Avatar
 
Join Date: May 2010
Posts: 499
I just replaced the blower motor control rheostat (there's another name but it's my 3rd glass of wine). It is behind the glove box after you remove foot kick housing. I went from no fan and hi to all fan speeds.
I also replaced the thermostat and had both hot and cold. The thermostat is PIA, until you learn to loosen the serpintine adjustment next to the power steering. Then you can take the housing off and replace with not problem.. As I recall it is 15mm. jj
__________________
jj
shipjim is offline   Quote
Old 11-12-2010, 12:26 PM   #5
Jeeper
 
Join Date: Aug 2009
Posts: 68
I had a one heat issue where the blower motor was only working on high.. in which case it was that resistor under the dash behind the glove box. Funny trick though I wound up fixing it by bending one of the contacts back ( because it broke off) now it works fine.
But my question now is I have only luke warm heat. Why is that I replaced the thermostat and its only warm. I know that it can be alot hotter. Anyone know what I can do to get it working again? is it the heater core? if so is it hard to replace?
imowt is offline   Quote
Reply

Tags
heater

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:04 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC