97 Wrangler Blower Problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-25-2010, 03:56 PM   #1
Newb
 
Join Date: Jan 2010
Posts: 4
Question 97 Wrangler Blower Problem

I have seen the other threads about the blower only working on High. But almost everything points to the resistor.
So here's my problem...
My heater blows very hot, but only on the highest setting. Nothing blows on 1, 2, or 3. I replaced the blower resistor this weekend, but it didn't help the situation. I then removed the head unit from the dash to see if the switch looked burned out or anything. It doesn't.
What else do I need to look at? Do I need a whole new head unit? please help. Thanks

TJWill is offline   Quote Quick Reply
Old 01-26-2010, 11:01 AM   #2
Jeeper
 
Join Date: Sep 2008
Location: Lake Village, IN
Posts: 58
I replaced my switch first when I ran across this problem. My blower controls only worked on low and high I believe. I found the price for a new switch and it was less than twenty dollars so I opted to try this first. And it solved my problem. All settings for the blower work now and have not had any problems following. I have a 99 wrangler. Might be an option for you. Also, just by looking at my old switch I could not visibly see anything wrong with it.

gmercer308 is offline   Quote Quick Reply
Old 02-01-2010, 01:43 PM   #3
Newb
 
Join Date: Jan 2010
Posts: 4
OK, I have now replaced the switch as well with no difference. Does anyone have any ideas on this? Thanks
TJWill is offline   Quote Quick Reply
Old 02-01-2010, 02:20 PM   #4
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,369
Images: 2
How closely did you examine the wiring harness between the switch and resistor pack? I have a '97 as well and my wiring was toast, I had to splice in new wiring at the same time I installed the new resistor pack.
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Reply

Tags
blower , heater

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
tj blower motor and airbag problem 04tjsahara TJ General Discussion Forum 3 06-14-2010 01:20 AM
Newbie with a Wrangler problem. supspt454 TJ Tech Forum 2 12-27-2009 12:24 AM
1990 wrangler 258 ping problem ccpanel YJ Tech Forum 14 05-29-2009 09:21 PM
Hey guys I'm working on my g/f's wrangler, need help, trans problem. qk99Cobra TJ Tech Forum 10 05-03-2009 04:38 PM
89 Wrangler YJ "4X4" Problem NEED HELP!! mburton12 YJ Tech Forum 7 03-18-2007 08:50 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:17 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC