97 Wrangler Electrical Issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-07-2012, 09:29 PM   #1
Newb
 
jeeptopia's Avatar
 
Join Date: Dec 2012
Location: Louisiana
Posts: 2
97 Wrangler Electrical Issue

My 97 Wrangler apears to have a short on the gauges. When the gauges are not working, the engine wonts start. If I turn the key sevral times, One of those times the gauges will wake up and then it starts. Funny because once it starts, it runs great. I already tested the CPS by unpluging it and gauges still have short. When I turn the key, I here a high pitch sound from the fuel pump. This sound keeps going till I turn ignition off. The Jeep sat for sevral months right before this started to happen. Any help would be appreciated! Thanks

jeeptopia is offline   Quote Quick Reply
Old 12-08-2012, 01:12 AM   #2
Jeeper
 
Join Date: Nov 2012
Location: New London
Posts: 193
Have you pulled the gauge cluster off of the dash frame, and checked for connection issues?! I put dielectric grease on all the contact points on mine before I reinstall it. I have zero experience with the no start issue, but I have worked on the gauges several times, and this may be worth a shot...

Sycboi is offline   Quote Quick Reply
Old 12-09-2012, 08:52 AM   #3
Newb
 
jeeptopia's Avatar
 
Join Date: Dec 2012
Location: Louisiana
Posts: 2
I'll try that. The only thing is that I'm thinking that even if there was a connection problem behind the gauges, it would still start up. Maybe not but ill try.
Thanks.
jeeptopia is offline   Quote Quick Reply
Old 12-09-2012, 01:05 PM   #4
Jeeper
 
RUBI 4 MY MRS's Avatar
 
Join Date: Feb 2011
Location: California/Nevada
Posts: 1,234
When the gauges don’t come on & it doesn’t start, do you mean the starter cranks the engine but it won’t start or you get nothing from the starter at all?

Also when this happens check 2 things, does the radio & heater fan come on if you have them turned on? If yes to this then go to the fuse block behind the glove box, find fuse 11 & see if it has power (12v). Do this by pulling the fuse & checking both terminals in the socket with a meter or test light. One of the 2 should have power (12v). Do all of this when the key is “on” & the gauges (cluster) are dead.

If the engine cranks but won’t start, the gauges are dead & fuse 11 has no power then the ignition switch is probably bad. Also the fact that you can get it going by turning the key a few times & eventually it works indicates a bad switch.

If you do need a new switch, there is a video of replacing the ignition switch here. It is about replacing the actuator pin but the switch is removed as part of that repair. You will need a t10 security bit or you can break the security pins out with a small punch & get it with a standard t10. Also look at the actuator pin, they are known to break, you might consider replacing it when you have it apart.

__________________


'05 Rubi TJ Unlimited
'93 Toyota 4Runner
RUBI 4 MY MRS is online now   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:41 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC