98 TJ no start (no spark) - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-01-2012, 08:55 PM   #1
Newb
 
Join Date: Jan 2012
Posts: 6
98 TJ no start (no spark)

I need help. I have wasted days and days on this thing. I was driving along one day and the jeep just died. Towed it home. I figured it was a fuel pump problem. It was taking a long time to start. Checked fuel pressure and it was good. Had.gas in it. It would just turn and turn. Well it sat for awhile. Well I go around checking things. Found a no spark condition. Talked with a lot of guys at the R/T forum and they suggested possibily a crank sensor. Well I looked Round. Short story long. Replaced the.crank sensor. Nothing. Checked a.ton of wiring. Fixed a few wires going to the coil. Nothing. Double checked fuel, sprayed some starting fluid down the TB. Nothing. Then I started messing with a scanner. It wouldn't talk to the computer or show any info. I then realized that my check engine light was not coming on at all. So I thought totally the ECU. That's another f'n negative. Bought it from auto computer exchange. Service sucked but cheapest around. Installed it. Cleaned the mounting surface. Plugged it in. NOTHING!. Still no freakin spark. Installed an MSD universal coil I had and as you know it. Nothing. What do I need to do? Bad rebuilt computer? My winter ride hit a tree and I am polluting the lousy roads of Indiana with tranny fluid. I NEED HELP!!! PLEASE.

Hobiesun is offline   Quote Quick Reply
Old 03-01-2012, 09:53 PM   #2
Jeeper
 
neverfastenough1's Avatar
 
Join Date: Nov 2010
Location: Savannah, Ga
Posts: 925
Checked the ground? Cam sensor? Distributor? ICM is a big issue these days.

neverfastenough1 is offline   Quote Quick Reply
Old 03-02-2012, 01:19 AM   #3
Newb
 
Join Date: Jan 2012
Posts: 6
I took the distributor out. Damn bolt snapped off the cap while trying to take it off. Fixed that, everything looked good. New cap and rotor. Here's the thing though, still no check engine light. Ever. Some one told me on another site that the.cam sensor feeds the injectors the signals, I really didn't believe it. I would think the ECU does all that. And my scanner will not talk to the ecm at all still. I fixed a lot of grounds. Rewired some messy wires. Checked all fuses and relays. ICM? I'm guessing that isn't done by the ecm? I guess it was a very well known problem for the crank sensor. But I guess not in this case. Without the scanner I can't really check the cam sensor or the crank sensor. The ICM, I realize ignition control module, where would that be? Thanks for your help. I'm down to gas and matches.
Hobiesun is offline   Quote Quick Reply
Old 03-14-2012, 11:40 PM   #4
Newb
 
Join Date: Jan 2012
Posts: 6
Hey guys. Still need some help. Found a hole and complete corrosion on the main power line A22 from the fuse block to the ECM. Fixed it, now I have complete computer control. However still no spark. I am getting a code p0351 Pri/Sec ignition wire. Followed the coil wires through the entire system I can not find anything. Any suggestions?
I threw a new coil on it. I noticed during long start attempts it was getting worm. I thought maybe I took it out while trying to find the problem but apparently not. Still no spark.
Hobiesun is offline   Quote Quick Reply
Old 03-18-2012, 07:15 PM   #5
Newb
 
Join Date: Aug 2005
Posts: 10
Same problem, same computer vendor. Replaced coil, check crank position sensor, it's ok, voltages in and out of connector checked out. New plugs, dist cap (screw broke also), rotor and wires.

Same result, no spark!
Tallpaul is offline   Quote Quick Reply
Old 03-18-2012, 07:26 PM   #6
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,153
Images: 2
Perhaps the crankshaft position sensor has gone bad, it provides the engine's master timing signal. You say it's ok but how did you check it?

The camshaft position sensor does indeed control the fuel injector timing.
__________________
When you have a choice, buy American.

Jerry Bransford is online now   Quote Quick Reply
Old 12-05-2012, 04:23 PM   #7
Newb
 
Surinamer's Avatar
 
Join Date: Dec 2012
Location: U.S. Embassy Port-au-Prince
Posts: 14
Resolution?

Did you ever solve the problem and if so, how? I am having the same problem w/ 2006 Unlimited.
__________________
Carpe diem!
Surinamer is offline   Quote Quick Reply
Old 06-29-2013, 01:50 PM   #8
Newb
 
Join Date: Jan 2012
Posts: 6
The new computer I bought from a reputable place never programmed it for my vin. I put the old computer back in and it fired right up. I will post the name of the company and bad mouth them as soon as I find the expensive paper weight.

Hobiesun is offline   Quote Quick Reply
Reply

Tags
computer , no spark

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel smell need help 1998 tj ncmountainbeeman TJ Tech Forum 10 11-03-2012 09:46 PM
TN: Stock 2004 TJ Jeep Wrangler Suspension ThatWhiteMachine101 Classifieds Archive 2 04-22-2012 05:13 PM
FL: TJ Front Hub-Bearing Assembly Chriso3030 Classifieds Archive 6 04-18-2012 08:04 AM
Got to finally drive my Tj this week!!! Chuckgalipeau TJ General Discussion Forum 2 03-01-2012 07:45 PM
TJ roll bars on a YJ? Options anyone? VBkidd22 YJ General Discussion Forum 2 03-01-2012 05:21 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:12 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC