99 Sahara overheating - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-20-2013, 10:21 AM   #1
Newb
 
Join Date: Jun 2013
Posts: 2
Question 99 Sahara overheating

My jeep temp reading after driving for several miles, started registering it was over heating. I pulled to the side of the road, but no steem coming from under the hood. I waited about 3-4 minutes and started driving again, and the temp went back to norm. I have replaced the radiator and thermostat about 7 months ago. Any ideas on what is happing???

Rich j is offline   Quote Quick Reply
Old 06-20-2013, 11:05 AM   #2
Jeeper
 
jeepstertj's Avatar
 
Join Date: Jun 2011
Location: mexico chihuahua
Posts: 191
How about the fan clutch? Is it in good condition?.
And if not maybe the water pump is damaged. First check the fan clutch. And if its ok check water pump.

jeepstertj is offline   Quote Quick Reply
Old 06-20-2013, 11:27 AM   #3
Newb
 
Join Date: Jun 2013
Posts: 2
Fan clutch seems fine. Would the water pump act intermintent???
Rich j is offline   Quote Quick Reply
Old 06-21-2013, 10:09 AM   #4
Jeeper
 
jeepstertj's Avatar
 
Join Date: Jun 2011
Location: mexico chihuahua
Posts: 191
Quote:
Originally Posted by Rich j View Post
Fan clutch seems fine. Would the water pump act intermintent???
No. Im pretty sure it cant. But i mean maybe the pump itself is damage or its not providing enough water circulation. Or well if you are lucky enough just remove the thermostat it could be getting stuck. But i will check first water pump and then thermostat.
jeepstertj is offline   Quote Quick Reply
Old 06-21-2013, 10:10 AM   #5
Jeeper
 
jeepstertj's Avatar
 
Join Date: Jun 2011
Location: mexico chihuahua
Posts: 191
Btw remember fan clutch should be hard to turn by hand when hot and easy when cold.
jeepstertj is offline   Quote Quick Reply
Old 06-21-2013, 11:13 AM   #6
Jeeper
 
MFsoftball22's Avatar
 
Join Date: Apr 2013
Location: Southern Illinois
Posts: 433
Did you flush and burp the cooling system after the repairs?

Why did you replace the T-stat and the radiator in the first place?

MFsoftball22 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 02:30 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC