99 TJ Acceleration Problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-28-2010, 09:17 PM   #1
Newb
 
Join Date: Feb 2010
Location: Utah
Posts: 12
99 TJ Acceleration Problems

Driving down to Moab today I ran into a strange problem. My jeep was about out of gas and started to severley hesitate when I accelerated. Filled it up, continued driving with no problems until about 70 miles later when it did the same thing full of fuel. When I try to accelerate it sounds like the engine shuts of then it slows down. It typically happens at higher speeds like 60 accelerating to go faster, and gradually happened at lower speeds. It is the 4.0 liter engine. It drives fine at lower speeds like around town, but I need to figure it out to hit the trails and get home. Has no fuel filter and I checked the vaccuum line, so I am guessing a fuel pump or computer issue. Any ideas out there or suggestions of mechanics down here in town? Thanks ahead for any feedback or assistance.

iluvfire is offline   Quote
Old 03-28-2010, 09:20 PM   #2
Jeeper

WF Supporting Member
 
Jp90Talon's Avatar
 
Join Date: Dec 2008
Location: CT
Posts: 3,154
What do you mean there isnt a fuel filter?

__________________
Jp90Talon is offline   Quote
Old 03-28-2010, 09:59 PM   #3
Newb
 
Join Date: Feb 2010
Location: Utah
Posts: 12
The 99 Wrangler doesn't have a seperate fuel filter. I believe it is part of the fuel pump. Talked to a few guys down here, went to a parts store, no fuel filter on the 99.
iluvfire is offline   Quote
Old 03-28-2010, 11:07 PM   #4
Jeeper

WF Supporting Member
 
Jp90Talon's Avatar
 
Join Date: Dec 2008
Location: CT
Posts: 3,154
Well im pretty sure there is a filter on the pick up of the pump...I would def consider that.
__________________
Jp90Talon is offline   Quote
Old 03-29-2010, 12:04 AM   #5
Jeeper
 
Join Date: Oct 2009
Location: San Diego
Posts: 759
maybe toyota built it! nah jk i still have full faith in Toyotas.
terrible2 is offline   Quote
Old 03-29-2010, 12:52 AM   #6
Jeeper
 
Join Date: Oct 2008
Posts: 111
Is your cat rattling?
chief100psu is offline   Quote
Old 03-29-2010, 11:25 AM   #7
Jeeper
 
pokey's Avatar
 
Join Date: Feb 2010
Location: backroads of the Mojave
Posts: 1,106
iluvfire is correct. The fuel filter (at least '99's) is in the tank and supposed to last the life of the vehicle. Did you check to see if you have any codes?
__________________
__________________________________________
. . . . picking the lines with my twenty-nines . . . .
__________________________________________

'99 sport 4.0 5 speed, top-of-the-line floormats
pokey is offline   Quote
Old 04-07-2010, 09:33 PM   #8
Newb
 
Join Date: Feb 2010
Location: Utah
Posts: 12
Problem resolved

Turns out it was the fuel pump. Dropped the tank and switched out the pump, now it runs like a champ. Thanks for the suggestions.

iluvfire is offline   Quote
Reply

Tags
99 tj , acceleration , fuel pump , problems , wrangler

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to fix all vacume problems and how to locate the problems. Captaincoop1220 YJ Tech Forum 50 02-23-2013 12:19 PM
No Lift. Vibration under hard acceleration in first gear cadamson YJ Tech Forum 2 03-18-2011 07:45 AM
YJ Problems sooboss YJ Tech Forum 12 08-18-2010 01:17 PM
Fuel injector cleaner caused major problems. NEED HELP!! dwilliams59 YJ Tech Forum 2 03-14-2008 10:52 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 08:51 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC