99 TJ Cluster Light Problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-02-2014, 02:51 AM   #1
Jeeper
 
Join Date: Mar 2013
Posts: 32
99 TJ Cluster Light Problem

Okay so I have a 99 TJ and the 4wd, ABS, Check engine, and airbag lights on the dash don't light up. I noticed this when doing the on off on off diagnostic test... I pulled the cluster checked the bulbs and they were all good. Sooo what could be the problem? I have also checked the fuses and there are no other lights out.

iamthewalrus016 is offline   Quote Quick Reply
Old 01-02-2014, 08:01 AM   #2
Jeeper
 
Join Date: Apr 2013
Posts: 2,253
You may not have ABS if you donT donT worry about that light

On normal key on not the cycling of diagnostic but just when you first turn key on the check engine and air bag should come on briefly as a bulb check and if you have the abs option it should also come on briefly
Does this happen?

Owners manual does not list 4wd as coming on for bulb check but does it work with putting transfer case in 4wd?

Did you swap in led dash lights as they are diodes and only work in one polarity so those that don't light may need to be reversed in their sockets

Digger84 is offline   Quote Quick Reply
Old 01-02-2014, 11:52 AM   #3
Jeeper
 
Join Date: Mar 2013
Posts: 32
No LEDS and I figure since I have an SE I wouldnt have ABS however there is a light in the socket. Also there is a light in the cruise and security that come on during diagnostics. I know I dont have cruise control but it still lights. The 4wd also doesnt light when it put into 4wd. I know it going in but it doesnt light. I thought it would be the sensor but when it didnt light with the diagnostic test I assumed it was the bulb after changing all the bulbs and realizing the ABS, Airbag, and check engine light also didnt come on during the test I got worried.
iamthewalrus016 is offline   Quote Quick Reply
Old 01-02-2014, 11:54 AM   #4
Jeeper
 
Join Date: Mar 2013
Posts: 32
oh and they dont light up during a bulb check when I crank over the Jeep for the bulb check.
iamthewalrus016 is offline   Quote Quick Reply
Old 01-02-2014, 12:48 PM   #5
Jeeper
 
Join Date: Mar 2013
Posts: 32
So on further inspection the ABS light does not light up probably because I dont have ABS... The Check engine, Check gauges, airbag, 4wd, and up shift dont illuminate during the diagnostic. Basically all the indicators on the right side of the cluster.
iamthewalrus016 is offline   Quote Quick Reply
Old 01-02-2014, 03:46 PM   #6
Jeeper
 
JimsJeep's Avatar
 
Join Date: Feb 2012
Location: Long Branch NJ
Posts: 1,239
4WD light test is not part of diagnostic test, probably a dead switch on the TC.
__________________
2000 Wrangler Metallic Fern Green
1999 Wrangler Chili Pepper Red
1976 Triumph TR6 British Racing Green
JimsJeep is online now   Quote Quick Reply
Old 01-02-2014, 03:54 PM   #7
SEX SYMBOL

WF Supporting Member
 
NH-JK's Avatar
 
Join Date: Oct 2013
Location: New Hampshire
Posts: 536
All my lights except the shift and 4x4 light light up on start up (97 4.0), I pulled my cluster and swapped in a new light bulb for the 4x4... Nothing either.
I'm assuming we have the same problem. I'm Going to swap out my 4x4 switch and I'll let you know if that helps. If you get to it before me, let us know if it worked. Good luck!
NH-JK is offline   Quote Quick Reply
Old 01-02-2014, 04:03 PM   #8
Jeeper
 
Join Date: Mar 2013
Posts: 32
Quote:
Originally Posted by JimsJeep View Post
4WD light test is not part of diagnostic test, probably a dead switch on the TC.
What about the Airbag, check engine, and check gauges? Shouldnt those light up when the test is run?

At first I just noticed the 4wd light not coming on. After I replaced the light bulb and it still didnt work I thought about the sensor on TC but I am reluctant to check that as I think my gauge cluster has a problem since there are other lights not coming on.

Also on my 97 TJ all the lights on the cluster illuminated during the test. My 99 has a couple lights my 97 didnt have like cruise and the security key light. I also find it strange that there is a light in the cruise when my TJ doesnt have cruise. I know the clusters are used for other vehicles but thought bulbs were left out on options that the vehicle didnt have
iamthewalrus016 is offline   Quote Quick Reply
Old 01-02-2014, 04:05 PM   #9
Jeeper
 
Join Date: Mar 2013
Posts: 32
Quote:
Originally Posted by NH-JK View Post
All my lights except the shift and 4x4 light light up on start up (97 4.0), I pulled my cluster and swapped in a new light bulb for the 4x4... Nothing either.
I'm assuming we have the same problem. I'm Going to swap out my 4x4 switch and I'll let you know if that helps. If you get to it before me, let us know if it worked. Good luck!
Yeah my 4wd drive light is probably my sensor on the TC but I am still concerned that the other lights dont come on during the diagnostic test. I mean I would hate for my TJ to pop a code and me not know because my check engine doesnt illuminate.
iamthewalrus016 is offline   Quote Quick Reply
Old 01-02-2014, 04:16 PM   #10
SEX SYMBOL

WF Supporting Member
 
NH-JK's Avatar
 
Join Date: Oct 2013
Location: New Hampshire
Posts: 536
My CEL and airbag light up... Have you checked the connections? there should be two, they are known to corrode on the early models...
NH-JK is offline   Quote Quick Reply
Old 01-02-2014, 04:24 PM   #11
Jeeper
 
Join Date: Mar 2013
Posts: 32
Yeah the connectors looked nice and clean but I think I may give them a little tweak and see if I can get a better contact.
iamthewalrus016 is offline   Quote Quick Reply
Old 01-02-2014, 05:03 PM   #12
Jeeper
 
JimsJeep's Avatar
 
Join Date: Feb 2012
Location: Long Branch NJ
Posts: 1,239
Quote:
Originally Posted by iamthewalrus016 View Post
What about the Airbag, check engine, and check gauges? Shouldnt those light up when the test is run?

At first I just noticed the 4wd light not coming on. After I replaced the light bulb and it still didnt work I thought about the sensor on TC but I am reluctant to check that as I think my gauge cluster has a problem since there are other lights not coming on.

Also on my 97 TJ all the lights on the cluster illuminated during the test. My 99 has a couple lights my 97 didnt have like cruise and the security key light. I also find it strange that there is a light in the cruise when my TJ doesnt have cruise. I know the clusters are used for other vehicles but thought bulbs were left out on options that the vehicle didnt have
Yes they are part of the diagnostic. Don't be surprised if you have a bad cluster, had to replace mine last fall when the CEL light would not go out. No codes but still would not pass inspection but $75 later it passed.
__________________
2000 Wrangler Metallic Fern Green
1999 Wrangler Chili Pepper Red
1976 Triumph TR6 British Racing Green
JimsJeep is online now   Quote Quick Reply
Old 01-02-2014, 05:05 PM   #13
Jeeper
 
RUBI 4 MY MRS's Avatar
 
Join Date: Feb 2011
Location: California/Nevada
Posts: 1,271
The 4wd & ABS are “hard wired” along with a few other things so they won’t light when doing the actuator test. The others should & here is what the FSM says if they don’t:

If an individual indicator lamp does not illuminate during the actuator test, the instrument cluster should be removed. However, check that the incandescent lamp bulb is not faulty and that the bulb holder is properly installed on the instrument cluster electronic circuit board before considering instrument cluster replacement. If the bulb and bulb holder check OK, replace the faulty instrument cluster.

I read that as the circuit board is bad & not supplied separately so you need a new cluster. I would check the board & if you find a bad spot maybe you can fix it. Mark which bulbs are dead & follow the circuit board, the bad spot is between the good bulbs & the dead ones.

This is all explained in the FSM under Instrument Panel Systems.

See online read only FSMs here:
Jeep Knowledge Base
You may have to go to the bottom of the page & pick Jeep Resources & online manuals if it directs you to home page rather than the knowledge base.
Pick your model & year then on the drop down menu pick the chapter you need.
__________________


'05 Rubi TJ Unlimited
'93 Toyota 4Runner
RUBI 4 MY MRS is offline   Quote Quick Reply
Old 01-02-2014, 05:31 PM   #14
Jeeper
 
Join Date: Mar 2013
Posts: 32
That is good to know about them being hard wired. I guess my next step is to check out the circuit board and go from there. I guess there will be a new instrument cluster in my future. I feel like it will be hard to find a cluster with under 100k.
iamthewalrus016 is offline   Quote Quick Reply
Old 01-02-2014, 05:37 PM   #15
Jeeper
 
Join Date: Mar 2013
Posts: 32
I also moved bulbs around and found a few that were faulty but the check engine, gauge, and airbag light still never illuminated nor did the 4wd when it was engaged. I am hoping all my lights come back after replacing the cluster... I really dont want to replace the sensor on the TC.
iamthewalrus016 is offline   Quote Quick Reply
Old 01-02-2014, 06:42 PM   #16
Jeeper
 
Join Date: Mar 2013
Posts: 32
Checked the circuit board and it was pretty clean. No signs of damage.
iamthewalrus016 is offline   Quote Quick Reply
Old 01-10-2014, 11:51 PM   #17
Jeeper
 
Join Date: Mar 2013
Posts: 32
Could this cluster light problem be related to a bad clockspring? I just realized my horn doesnt work either...

iamthewalrus016 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:12 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC